Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32466 - [systemd, udisks] Can't mount ntfs partition as unprivileged user

Attached to Project: Arch Linux
Opened by Nicola Mori (snack) - Sunday, 04 November 2012, 20:34 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Sunday, 04 November 2012, 21:21 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since the switch to systemd I am unable to mount ntfs partitions as unprivileged user with udisks (it worked previously with sysvinit). The relevant /etc/fstab entry is:
UUID=88705BA9705B9D2E /media/vista ntfs-3g noauto,users,exec 0 0

ntfs-3g has been compiled with internal fuse support and:
$ ll `which ntfs-3g`
-rwsr-xr-x 1 root root 125K 16 apr 2012 /bin/ntfs-3g

I can mount from cli:
$ mount /dev/sda2
$

while using udisks I get:
$ /usr/bin/udisks --mount /dev/sda2
Mount failed: Error mounting: mount exited with exit code 1: helper failed with:
Error opening '/dev/sda2': Permesso negato
Failed to mount '/dev/sda2': Permesso negato
Please check '/dev/sda2' and the ntfs-3g binary permissions,
and the mounting user ID. More explanation is provided at
http://tuxera.com/community/ntfs-3g-faq/#unprivileged

Commenting out the /etc/fstab line I am asked for password and then mount works.

Additional info:
* package version(s)
systemd 195-2
udisks 1.0.4-5
ntfs-3g 2012.1.15-2 with internal fuse support
Tested only on x86_64, no info about i686

Forum thread:
https://bbs.archlinux.org/viewtopic.php?id=151061


Steps to reproduce:
described above
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Sunday, 04 November 2012, 21:21 GMT
Reason for closing:  Not a bug
Comment by Daniel Wallace (gtmanfred) - Sunday, 04 November 2012, 20:38 GMT
https://wiki.archlinux.org/index.php/General_Troubleshooting#Session_permissions

you need polkit-gnome or polkit-qt to mount internal hard drives in a user session

otherwise, it is working correctly, if you are in the wheel group it asks for your password, otherwise it asks for the root password
Comment by Nicola Mori (snack) - Sunday, 04 November 2012, 20:51 GMT
Thanks, there's no documentation on the necessity to install polkit-gnome or polkit-qt in the wiki. At least, nothing I have been able to find (also the link you posted is not very clear to me).
Anyway, I installed polkit-qt (I'm using KDE with KDM) but cli mount from konsole still does not work:

$ pacman -Qs polkit-qt
local/polkit-qt 0.103.0-1
A library that allows developers to access PolicyKit API with a nice Qt-style API
$ /usr/bin/udisks --mount /dev/sda2
Mount failed: Error mounting: mount exited with exit code 1: helper failed with:
Error opening '/dev/sda2': Permesso negato
Failed to mount '/dev/sda2': Permesso negato
Please check '/dev/sda2' and the ntfs-3g binary permissions,
and the mounting user ID. More explanation is provided at
http://tuxera.com/community/ntfs-3g-faq/#unprivileged

Do I need to manually configure something? Sorry for bothering but informations on the wiki are really scarce. Thanks.
Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 04 November 2012, 21:21 GMT
Using fstab for this purpose will makes things probably broken. Remove such entry. And if such disk is not "removable" should add the proper polkit rule. Please ask in forums.

Loading...