Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32427 - [bluez] org.bluez.service should be named dbus-org.bluez.service

Attached to Project: Arch Linux
Opened by Greg (dolby) - Saturday, 03 November 2012, 18:06 GMT
Last edited by Ionut Biru (wonder) - Sunday, 04 November 2012, 00:16 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tom Gundersen (tomegun)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

/usr/share/dbus-1/system-services/org.bluez.service should be named
/usr/share/dbus-1/system-services/dbus-org.bluez.service

As can be seen in /usr/lib/systemd/system/bluetooth.service:

Alias=dbus-org.bluez.service

or the /usr/share/dbus-1/system-services/org.bluez.service" file itself:

SystemdService=dbus-org.bluez.service

Otherwise pulseaudio and probably other things cant start bluez:

pulseaudio[253]: [pulseaudio] bluetooth-util.c: org.bluez.Manager.ListAdapters() failed: org.freedesktop.systemd1.LoadFailed: Unit dbus-org.bluez.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.bluez.service' for details.
pulseaudio[253]: [pulseaudio] module-gconf.c: Unable to read or parse data from client.
pulseaudio[253]: [pulseaudio] module.c: Failed to load module "module-gconf" (argument: ""): initialization failed.
pulseaudio[253]: [pulseaudio] main.c: Module load failed.
This task depends upon

Closed by  Ionut Biru (wonder)
Sunday, 04 November 2012, 00:16 GMT
Reason for closing:  Not a bug
Comment by Greg (dolby) - Saturday, 03 November 2012, 18:08 GMT
And these as well:
dbus-daemon[206]: dbus[206]: [system] Activation via systemd failed for unit 'dbus-org.bluez.service': Unit dbus-org.bluez.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.bluez.service' for details.

dbus[206]: [system] Activating via systemd: service name='org.bluez' unit='dbus-org.bluez.service'
dbus[206]: [system] Activation via systemd failed for unit 'dbus-org.bluez.service': Unit dbus-org.bluez.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.bluez.service' for details.
Comment by Ionut Biru (wonder) - Saturday, 03 November 2012, 18:15 GMT
dbus interfaces should't be renamed. if you rename them, then all the apps relaying on the old name will break.

dbus interfaces are not regular systemd daemons.
Comment by Greg (dolby) - Saturday, 03 November 2012, 18:17 GMT
I meant renaming the file in /usr/share/dbus-1/system-services/org.bluez.service to /usr/share/dbus-1/system-services/dbus-org.bluez.service
Not the interface. Sorry if that wasnt clear.
Comment by Ionut Biru (wonder) - Saturday, 03 November 2012, 18:18 GMT
yeah, that shouldn't be renamed.
Comment by Greg (dolby) - Saturday, 03 November 2012, 18:22 GMT
Whats the solution then? Not even dbus itself can find it.
Comment by Greg (dolby) - Saturday, 03 November 2012, 18:27 GMT
I also get the same for avahi:
dbus-daemon[206]: dbus[206]: [system] Activating via systemd: service name='org.freedesktop.Avahi' unit='dbus-org.freedesktop.Avahi.service'
dbus[206]: [system] Activating via systemd: service name='org.freedesktop.Avahi' unit='dbus-org.freedesktop.Avahi.service'
dbus-daemon[206]: dbus[206]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.Avahi.service': Unit dbus-org.freedesktop.Avahi.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.Avahi.service' for details.
dbus[206]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.Avahi.service': Unit dbus-org.freedesktop.Avahi.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.Avahi.service' for details.
Comment by Tom Gundersen (tomegun) - Saturday, 03 November 2012, 18:29 GMT
I'm afraid Ionut is right.

The situation is slightly confusing as both dbus and systemd use the .service postfix. However, the naming of both are correct.

The error message should be improved (though I don't know what wording would be better).

Try "systemctl enable bluetooth.service", that should make it work, as it creates the missing Alias (symlink) dbus-org.bluez.service in /etc/systemd/system. Assuming that works, this is not a bug.
Comment by Greg (dolby) - Sunday, 04 November 2012, 00:06 GMT
If i systemctl enable bluetooth.service it works.

Loading...