Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32426 - 0.6.20-1

Attached to Project: Arch Linux
Opened by Ernestas (ernetas) - Saturday, 03 November 2012, 17:28 GMT
Last edited by Evangelos Foutras (foutrelis) - Monday, 05 November 2012, 21:33 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
After upgrading duplicity to 0.6.20-1, deja-dup started asking for Encryption password, but my backups are not encrypted. Deleting backups and trying to run a clean backup does not help either.

Additional info:
* Duplicity: 0.6.20-1
* deja-dup: 24.0-1


Steps to reproduce:
1. Launch deja-dup-preferences.
2. Click Back Up Now.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Monday, 05 November 2012, 21:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in duplicity-0.6.20-2 and deja-dup-24.0-2.
Comment by Ernestas (ernetas) - Saturday, 03 November 2012, 17:28 GMT
Sorry for bad title, I forgot to change it. Also, backups are stored in Ubuntu One.
Comment by Balló György (City-busz) - Sunday, 04 November 2012, 03:55 GMT
I don't really understand the problem. When you make a backup at first time, deja-dup asks you if you want to password-protect your backup or not. If you choose 'Allow restoring without a password', deja-dup will never ask this question again.
Comment by Ernestas Lukosevicius (Ernestas) - Sunday, 04 November 2012, 16:47 GMT
I did choose "Allow restoring without a password", but it started asking me for the password whether I want to restore or to backup to Ubuntu One. I also deleted all backups on Ubuntu One, but the problem persists. There seems to be no problems with local backups.
Here it is in action: http://youtu.be/gSTalNlzqak?hd=1
Comment by Balló György (City-busz) - Monday, 05 November 2012, 16:49 GMT
Okay, now I see that the U1 backend was rewritten, and deja-dup needs to be fixed. Please try with these packages:
http://pkgbuild.com/~bgyorgy/packages/

Edit:
- python2-ubuntuone-couch is no longer needed for U1 backup
- I experienced unicode error on non-english local
Comment by Ernestas Lukosevicius (Ernestas) - Monday, 05 November 2012, 18:21 GMT
Thanks! It is now fixed. Will it go to ArchLinux repositories or could you create a patch for AUR packages?
Comment by Balló György (City-busz) - Monday, 05 November 2012, 20:17 GMT
Fixed in [community].

Loading...