Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32424 - [miro] no longer starts after gstreamer and gnome update

Attached to Project: Arch Linux
Opened by Adoa Coturnix (adoa) - Saturday, 03 November 2012, 14:09 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 06 November 2012, 14:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Ronald van Haren (pressh)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

After update of Gnome to 3.6 and Gstreamer, Miro no longer starts. Maybe there is a problem with policykit or consolekit removal.

Additional info:

More than one user is affected:
https://bbs.archlinux.org/viewtopic.php?id=151873

package versions:

gstreamer 1.0.2-1
gstreamer0.10 0.10.36-1
miro 5.0.4-2

Starting Miro in a terminal gives error messages (see attachment)

Steps to reproduce:

1. Try to start Miro
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 06 November 2012, 14:22 GMT
Reason for closing:  Fixed
Comment by Javier Viñal (fjvinal) - Saturday, 03 November 2012, 20:32 GMT
I have the same problem (using KDE).
Comment by Ronald van Haren (pressh) - Sunday, 04 November 2012, 21:14 GMT
I'm looking into this but haven't found yet why 'from _gst import *' just hangs...

Any idea what update (or set of updates) exactly cuased this?
Comment by György Balló (City-busz) - Monday, 05 November 2012, 05:58 GMT
Ronald, I received a very similar bug report about nauilus-sound-converter:  FS#32467 
Comment by Ronald van Haren (pressh) - Monday, 05 November 2012, 08:21 GMT
@Jan: Any idea?
Comment by György Balló (City-busz) - Monday, 05 November 2012, 19:56 GMT
Downgrading webkitgtk2 1.10.1-1 to libwebkit 1.8.3-1 solves the problem. I think it's probably caused because webkitgtk2 uses gstreamer 1.0, but miro uses gstreamer 0.10, and loading the two libraries in the same process causes conflict.
Comment by Ronald van Haren (pressh) - Tuesday, 06 November 2012, 07:56 GMT
Okay, thanks for the pointer. I'll look into it if I can make some compat packages if I have more time.
Comment by Jan de Groot (JGC) - Tuesday, 06 November 2012, 12:31 GMT
I'm changing webkitgtk2 to use GStreamer 0.10 instead of 1.0. Reason behind this is the fact that applications still using GTK2 will probably also still use GStreamer 0.10 or the other way around.
So far the only package that makes an exception to this rule is Banshee, which we patched to compile with GStreamer 1.0.
Comment by Jan de Groot (JGC) - Tuesday, 06 November 2012, 13:43 GMT
Please try new webkitgtk2.
Comment by György Balló (City-busz) - Tuesday, 06 November 2012, 14:02 GMT
Miro works well with webkitgtk2 1.10.1-2.

Loading...