Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32404 - [gtk3] uses annoying suggestions for filenames

Attached to Project: Arch Linux
Opened by Ernestas (ernetas) - Friday, 02 November 2012, 18:23 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Sunday, 04 November 2012, 21:29 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: see the bug on video: https://dl.dropbox.com/s/hrxs8v4u0s3r9uy/evince%20bug.ogv?dl=1


I don't know how to exactly put this, but the filename suggestions are extremely annoying, when browsing through folders. Check out the video for more information.
I suggest turning them completely off or at least when the input field is empty.

Additional info:
*evince 3.6.1-1


Steps to reproduce:

I need help determining whether this is really evince and not GTK fault, so to know to which upstream should I report the problem.
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Sunday, 04 November 2012, 21:29 GMT
Reason for closing:  Upstream
Comment by Ernestas (ernetas) - Friday, 02 November 2012, 18:27 GMT
Forgot to add steps to reproduce...
There are many ways. Here's just one of them:
1. Open evince.
2. Hit Ctrl+O
3. Move away from the current folder to a folder with PDFs.
4. Delete the field input.
5. Optionally, you can make sure that the mouse cursor is not in the field, but, say, on the Cancel button by using Tab.
6. Move back to another folder with PDFs.
7. Here you go - for somewhat unknown reason you get full folder contents as suggestions for the filename.

Something similar can be reproduced with Transmission GTK and other GTK programs, but I am not sure whose problem exactly it is and it varies a bit depending on the software.
Comment by Greg (dolby) - Friday, 02 November 2012, 23:00 GMT
Those are filenames you use for your documents. Evince doesnt make them up.
Comment by Alexander F. Rødseth (xyproto) - Friday, 02 November 2012, 23:06 GMT
Thanks for reporting. For reporting this upstream, I would suggest reporting it to the evince developers. If you do, please include a link to the bug report here. Thanks.
Comment by Ernestas (ernetas) - Friday, 02 November 2012, 23:25 GMT
I'm not saying evince makes up the filenames. They are not a history for filenames used in evince. They are the contents of the current folder. There are two issues here:
1. Suggested filenames are not just PDFs and folders.
2. Why do I need this suggestion if I am just moving around the folders? I NEVER use the filename input box for evince and it annoys when I have to click somewhere else to be able to see the filelist again, even though as I said, I don't use the filename input box.

The problem is the same for Transmission, so I guess it is not just about evince and it would improper to fill a bug report for theirs upstream.
Comment by Greg (dolby) - Friday, 02 November 2012, 23:29 GMT
Its GTK+.
Comment by Ernestas (ernetas) - Friday, 02 November 2012, 23:30 GMT
Thanks! Just wanted to make sure that it's not some kind of other lib or GNOME package. :) I'll get back here with a link to bug in the upstream.
Comment by Ernestas (ernetas) - Saturday, 03 November 2012, 15:44 GMT
https://bugzilla.gnome.org/show_bug.cgi?id=687514 - bug report at GNOME Bugzilla for GTK+.

Loading...