Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32397 - [subversion] missing /run/svnserve directory for pidfile

Attached to Project: Arch Linux
Opened by Muflone (muflone) - Friday, 02 November 2012, 16:30 GMT
Last edited by Stéphane Gaudreault (stephane) - Monday, 05 November 2012, 15:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Stéphane Gaudreault (stephane)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The package subversion doesn't provide the /run/svnserve directory where the pidfile will be stored as requested from /usr/lib/systemd/system/svnserve.service.
The service file will be unable to start the SVN server until the /run/svnserve directory is manually created.

Additional info:
* package subversion 1.7.7-1 for x86_64

Steps to reproduce:
1- install the subversion package
2- setup the svn root path in the /etc/conf.d/svnserve like:
SVNSERVE_ARGS="-r /media/Sources/SVN"
3- start the service with systemctl start svnserve
svnserve.service - Subversion protocol daemon
Loaded: loaded (/usr/lib/systemd/system/svnserve.service; enabled)
Active: failed (Result: exit-code) since Fri, 2012-11-02 17:13:31 CET; 1min 47s ago
Process: 18756 ExecStart=/usr/bin/svnserve --daemon --pid-file=/run/svnserve/svnserve.pid $SVNSERVE_ARGS (code=exited, status=0/SUCCESS)
Main PID: 18757 (code=exited, status=1/FAILURE)
CGroup: name=systemd:/system/svnserve.service
4- nothing happens, no errors or logs are reported
5- mkdir /run/svnserve
6- start the service again and it will work fine
This task depends upon

Closed by  Stéphane Gaudreault (stephane)
Monday, 05 November 2012, 15:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  subversion-1.7.7-2 in [testing]
Comment by Dave Reisner (falconindy) - Friday, 02 November 2012, 17:18 GMT
The problem is rather that the tmpfiles fragment isn't processed on install/upgrade. If you run 'systemctl-tmpfiles --create svnserve.conf' or just reboot, this will work fine.

Loading...