Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32390 - [banshee] Segfault when playing music

Attached to Project: Arch Linux
Opened by Raphaël Rochet (Raphael) - Friday, 02 November 2012, 09:47 GMT
Last edited by Jan de Groot (JGC) - Thursday, 13 December 2012, 20:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 37
Private No

Details

Description:

Banshee crashes. Seems that it is DBus related : there's a warning "Got Disconnected from DBus".
Note that in console it says 'GStreamer version 1.0.1.0' however it is dependant on gst-plugins-base 1.0.2-1

This error appeared after gnome-shell update to 3.6 (not using testing).

Additional info:
* package version(s)
extra/banshee 2.6.0-1
extra/gst-plugins-base 1.0.2-1

I have attached console output.

Steps to reproduce:
Use banshee even when not doing anything it crashes itself soon.
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 13 December 2012, 20:09 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Though this bug was first,  FS#32927  describes the actual problem.
Comment by Raphaël Rochet (Raphael) - Friday, 02 November 2012, 09:54 GMT
Sorry forgot the log. Here it is.
Comment by Anthony Ruhier (Anthony25) - Friday, 02 November 2012, 12:54 GMT
I have the same bug after the update for gnome 3.6 and banshee 2.6.

I don't post the log, it's exactly the same as Raphael's.
Comment by Jan de Groot (JGC) - Friday, 02 November 2012, 14:54 GMT
Your traces are identical to something another user posted in another bugreport using 2.4 (which is closed already because that bug was fixed by a gconf update).

Looking at the traces, it seems Banshee is having trouble retrieving things from GConf and crashes doing so. Can you point out any reason for the "Lost connection to D-Bus" warnings you get? Did you restart/kill the dbus session bus for example?
Comment by Raphaël Rochet (Raphael) - Friday, 02 November 2012, 15:03 GMT
No apparent reason for me.

Here is another log. This times it crashes when I tried to open options (trying to disable replaygain).
Comment by Raphaël Rochet (Raphael) - Friday, 02 November 2012, 15:21 GMT
Here are two others. This time Replaygain is disabled (dunno if matters)

In the two cases here, I just launch Banshee, started playback, adjust volume via sound applet (banshee always set my volume to maximum and its volume control does not work well) and eventually tried to skip to next track.

The first time it crashed with trace about dbus and gconf.

The last time it crashes with something about glibc :
*** glibc detected *** banshee: invalid fastbin entry (free): 0x000000000349d3f0 ***

Just in case, I tried to compile banshee from source : there is the same behavior. (DBus related error)
( juste saying "GStreamer version 0.10.36.0" instead of "GStreamer version 1.0.1.0" )
Comment by Jan de Groot (JGC) - Friday, 02 November 2012, 15:28 GMT
Please update your gconf package, your last trace shows a segfault due to a bug that was fixed in the last gconf package that I updated on wednesday.
Comment by Raphaël Rochet (Raphael) - Friday, 02 November 2012, 15:46 GMT
Shame on me. Will do ASAP.
Comment by Raphaël Rochet (Raphael) - Friday, 02 November 2012, 15:54 GMT
I have gconf 3.2.5-3, and don't see newer version in repo. Maybe not the same bug ?
Comment by Anthony Ruhier (Anthony25) - Friday, 02 November 2012, 17:26 GMT
I have gconf 3.2.5-3 too...
Comment by Angelo Platti (berseker) - Sunday, 04 November 2012, 08:06 GMT
same bug, same gconf version installed
Comment by Hector Mtz-Seara Monne (hseara) - Sunday, 04 November 2012, 09:25 GMT
I have the same problem with the system fully updated. I use xfce. I have attached also the console output. There are two different crashes. They usually happen when I change of album although also within the album. Usually I do not have to wait long half minute most of the cases.

Also I noticed that the volume behaves weirdly. I'm not sure if the problem is unrelated but who knows as they both started after the update to gnome 3.6. I can mute and unmute the channel using the mute keyboard button. I can also put up and down the volume without problems unless I mute the channel completely by pressing the lower volume key. At this point I cannot recover the sound with the volume keys. I have to use either pavucontrol, the volume bottom of banshee. The Audio mixer xfce applet becomes unresponsive. In pulseaudio it looks that banshee decouple from the master. I do not know how to explain better as it is very weird. I can give more details if needed. I can also open a new bug report if you think is unrelated.
Comment by Raphaël Rochet (Raphael) - Sunday, 04 November 2012, 09:35 GMT
If that matters, I have also weird volume behavior with Banshee's volume control button, it sets the volume too loud in pulseaudio.

Also, on another laptop running 32 bit archlinux, volume control is ok and banshee does not crash.
Comment by Nate G. (nateg3.14159) - Sunday, 04 November 2012, 23:49 GMT
This happens to me as well, after the update to gnome 3.6 and gstreamer 1.0
I have gconf 3.2.5-3 installed as well.

Log attached
Comment by Nate G. (nateg3.14159) - Monday, 05 November 2012, 00:42 GMT
Just got a second error
Comment by Marc (ttux) - Monday, 05 November 2012, 08:39 GMT
I have the same problem. Could it be gstreamer 1.0 related?
Comment by Isenmann Daniel (ise) - Monday, 05 November 2012, 09:14 GMT
I don't have any crash, it runs without any error.
Comment by Raphaël Rochet (Raphael) - Monday, 05 November 2012, 09:24 GMT
Are you running 32 or 64 bits ?

I have both here, and Banshee crashes only with 64bits install.
Comment by Isenmann Daniel (ise) - Monday, 05 November 2012, 09:27 GMT
64bits and no problems. Do you have some plugins installed which are not compatible or anything?
Comment by Raphaël Rochet (Raphael) - Monday, 05 November 2012, 09:47 GMT
I've disabled all extensions, gapless playback, replaygain, all ! And still crashing :(
(This time there is no seg fault but stack overflows)

I have all gst packages installed, both 1.0.2 and 0.10 :

extra/gst-libav 1.0.2-1
extra/gst-plugins-bad 1.0.2-1
extra/gst-plugins-base 1.0.2-1
extra/gst-plugins-base-libs 1.0.2-1
extra/gst-plugins-good 1.0.2-1
extra/gst-plugins-ugly 1.0.2-1
extra/gstreamer 1.0.2-1

extra/gstreamer0.10 0.10.36-1
extra/gstreamer0.10-bad 0.10.23-3
extra/gstreamer0.10-bad-plugins 0.10.23-3
extra/gstreamer0.10-base 0.10.36-1
extra/gstreamer0.10-base-plugins 0.10.36-1
extra/gstreamer0.10-ffmpeg 0.10.13-1
extra/gstreamer0.10-good 0.10.31-1
extra/gstreamer0.10-good-plugins 0.10.31-1
extra/gstreamer0.10-ugly 0.10.19-2
extra/gstreamer0.10-ugly-plugins 0.10.19-2

The volume control in Banshee is ok for you ? Smooth and not going over 100% ?
Comment by Marc (ttux) - Monday, 05 November 2012, 12:49 GMT
64bits, I disabled all plugins, still crashing with a segfault. No stacktrace on this one, just this:
(Banshee:9241): GConf-WARNING **: Got Disconnected from DBus.

I have no problem with volume control but it might be due to something I have set in /etc/pulse/default.pa:
load-module module-udev-detect tsched=0 ignore_dB=1

It's the ignore_dB=1, it makes that when increasing the volume, only master goes up (and not PCM). But anyway, this isn't related to this bug.

I tried again and got banshee_stacktrace1.txt

Then another try and got banshee_stacktrace2.txt

Comment by Marc (ttux) - Monday, 05 November 2012, 13:06 GMT
It seems I got it working. I noticed the following messages when doing a pacman -Syu for some packages:
(gconftool-2:4000): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

After googling a bit I found this:
https://bbs.archlinux.org/viewtopic.php?pid=1187978

I re-installed gconf with sudo (I already had gconf-3.2.5-3 installed) and now banshee doesn't seem to crash anymore but I still get this in the console:
(Banshee:9617): GConf-WARNING **: The connection to DBus was broken. Can't reinitialize it.
[Warn 14:03:48.843] Could not set GConf key player_window.source_view_width. - GLib.GException: No D-BUS daemon running
(in `gconf-sharp')
at GConf.Client.SetValue (System.String key, GConf.Value val) [0x00000] in <filename unknown>:0
at GConf.ClientBase.Set (System.String key, System.Object val) [0x00000] in <filename unknown>:0
at Banshee.GnomeBackend.GConfConfigurationClient.Set[Int32] (System.String namespace, System.String key, Int32 value) [0x00000] in <filename unknown>:0

But as it works, I don't care much.
Comment by Raphaël Rochet (Raphael) - Monday, 05 November 2012, 13:21 GMT
Too bad I don't have your luck. I reinstalled gconf but this didn't change anything.

Edit: also reinstalled banshee and removed all gstreamer0.10 -related package, still no luck.
Comment by Marc (ttux) - Monday, 05 November 2012, 14:13 GMT
But did you re-install it with sudo and a normal user?
Comment by Raphaël Rochet (Raphael) - Monday, 05 November 2012, 14:42 GMT
Yes, "sudo pacman -Rdd gconf" and "sudo pacman -S gconf".

Got a new error once :
*** glibc detected *** banshee: malloc(): memory corruption (fast): 0x0000000001a031c0 ***

Next times it was the (sadly) usual segfault.

I guess it's hard to find a bug when it's not reproductible, I hope someone will eventually find *the* clue ...
Comment by Anthony Ruhier (Anthony25) - Monday, 05 November 2012, 19:23 GMT
I post my log file (I have different errors, it's quite random...).
Comment by Anthony Ruhier (Anthony25) - Tuesday, 06 November 2012, 19:45 GMT
I updated banshee today to the 2.6.0-2 version.

Banshee doesn't seem to crash if I launch it in a terminal (unless if I send the --debug parameter), but it crash if I launch it with the shortcut.

When I launch it in a terminal I have this error (repeated few times) :


(Banshee:10169): GConf-WARNING **: The connection to DBus was broken. Can't reinitialize it.

[Warn 20:46:31.081] Could not read GConf key sources.MusicLibrarySource-Library.status_format - GLib.GException: Aucun service D-BUS en cours d'exécution
(in `gconf-sharp')

at GConf.Client.Get (System.String key) [0x00000] in <filename unknown>:0
at Banshee.GnomeBackend.GConfConfigurationClient.TryGet[Int32] (System.String namespace, System.String key, System.Int32& result) [0x00000] in <filename unknown>:0
Comment by Raphaël Rochet (Raphael) - Tuesday, 06 November 2012, 21:02 GMT
Updated too. But unfortunately nothing changed but GStreamer version.

Played a little with "banshee --debug", and for the first time I saw errors about source code (complete error in log attached)

at Booter.Booter.Main () [0x000f1] in /build/src/banshee-2.6.0/src/Clients/Booter/Booter/Entry.cs:105
at (wrapper runtime-invoke) object.runtime_invoke_void (object,intptr,intptr,intptr) <IL 0x0004c, 0xffffffff>
Comment by Anthony Ruhier (Anthony25) - Tuesday, 06 November 2012, 21:15 GMT
Did you try to launch Banshee in a terminal without --debug (just $ banshee) ?
Comment by Raphaël Rochet (Raphael) - Tuesday, 06 November 2012, 21:41 GMT
Yes, and most of the time, it crashes soon.
If not, then it seems it won't at all ... yes some times I could play many tracks without crashing.

The warning about broken connection to DBus doesn't pop everytime neither. And when banshee crashes, there's not always the DBus error. And when it's working and playing the DBus error is flooding the console.
Comment by Nate G. (nateg3.14159) - Wednesday, 07 November 2012, 03:46 GMT
Yet another error, after a full system update.
Just for the record, half the time it crashes as soon as i try to play a song, sometimes it will crash on the second or third song, and maybe once every 10 launches it will let me play music with no issues.
Output is just from running "$ banshee" from the terminal. No --debug
Comment by Nate G. (nateg3.14159) - Wednesday, 07 November 2012, 03:51 GMT
And when running with --debug, upon hitting the button to go to the previous song, I got:
[1 Debug 19:48:56.028] Player state change: Loaded -> Playing
Stacktrace:

Stack overflow: IP: 0x5ce6bc, fault addr: (nil)
Stacktrace:
Segmentation fault
Comment by Andy Botting (andybz) - Wednesday, 07 November 2012, 04:21 GMT
I also use Tomboy, and I've been seeing it crash when trying to sync my notes.

(Tomboy:17955): GConf-WARNING **: Got Disconnected from DBus.
Native stacktrace:
Segmentation fault

I would imagine that the common thing between Banshee and Tomboy is Mono. Seems that there must be an issue between Mono and DBus.
Comment by Ariel (karamaz0v) - Thursday, 08 November 2012, 01:19 GMT
64bit here, banshee 2.6.0-2, fully updated system. I'm also getting the error

Native stacktrace:

Segmentation fault

tried the "sudo pacman -Rdd gconf" and "sudo pacman -S gconf" workaround with no success.

In my case the bug it's quite reproductible, independently if I run it from the app icon, or the terminal with or without --debug, it always crashes when it finishes playing the current song and should start playing the following one. It never crashes before finishing the current playing song.
If I switch songs by hand, it keeps running no matter how many times I change, between songs in the same album or different ones.
Comment by John Piers (johnpiers) - Thursday, 08 November 2012, 09:12 GMT
My problem is identical to Ariel's description above. Is there any light at the end of the tunnel? Banshee is the only thing (Besides Chromium) that I normally use on a daily basis and can't live without my precious music player!
Comment by Jan de Groot (JGC) - Thursday, 08 November 2012, 21:50 GMT
Can people seeing "GConf-WARNING **: The connection to DBus was broken. Can't reinitialize it." try to upgrade gvfs? I've added some upstream commits that fix tampering shared dbus connections.
Comment by Anthony Ruhier (Anthony25) - Thursday, 08 November 2012, 22:44 GMT
Upgrading gvfs to gvfs-git fix the Dbus problem, but not the crash problem.

Edit : I have updated my mirrorlist, I'm going to test with the official packages ;)
Comment by Anthony Ruhier (Anthony25) - Thursday, 08 November 2012, 23:13 GMT
It seems to work (no need to launch it in a terminal to make it works anymore), I will tell you tomorrow or in a few days if it fix the bug.

Edit : Banshee just crashed few minutes ago (I have reboot since the gvfs update), so it seems it fix only the Dbus bug.
You can find the error in attachment.
Comment by Nate G. (nateg3.14159) - Friday, 09 November 2012, 01:21 GMT
Still crashing after updating gvfs.
Slightly different error message.
Comment by Ariel (karamaz0v) - Saturday, 10 November 2012, 00:05 GMT
i've just upgraded everything, still getting the

Native stacktrace:
Segmentation fault

in the same situation I described above.
Comment by Jonathan Dlouhy (oboedad55) - Saturday, 10 November 2012, 07:18 GMT
I'm getting the same instant crash, but with this error:
=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Comment by John Piers (johnpiers) - Saturday, 10 November 2012, 10:28 GMT
This is what's happening when I run Banshee from the terminal, a whole bunch of new errors. Prior to this is was usable with dbus errors, but was not crashing, now basically after every song it crashes.
   banshee (7.6 KiB)
Comment by Ryan (ryan) - Saturday, 10 November 2012, 11:48 GMT
If it helps, if I play radio, I have not had banshee crash, though if I were to play mp3's or flac's from my local pc, it is mostly random when it will crash, but generally when changing tracks.

Output is running "banshee --debug" and seems to be from mono.
   banshee (27.7 KiB)
Comment by jack (jackgu1988) - Saturday, 10 November 2012, 23:14 GMT
Got this when rescanning library. Crashes every 10-20% of the the scan.
   banshee (10.4 KiB)
Comment by Kevin Knerr (barthel) - Monday, 12 November 2012, 15:29 GMT
I'm in much the same boat after doing a full system upgrade yesterday. (Last one was 22 days earlier when I switched to pure systemd.) At first the crashes were intermittent, but now banshee crashes shortly after launch without me doing anything.

After downgrading to 2.4.1, banshee plays stably although it throws out constant GConf/DBUS errors.

I've attached terminal output from the crash of 2.6.0, followed by launching 2.4.1 (from which I exited cleanly).

Hopefully this will help track down the real source of the bug. (I spent most of yesterday trying out other players again and I really like banshee best now...)
Comment by John Piers (johnpiers) - Tuesday, 13 November 2012, 23:26 GMT
Is there any resolution in sight for this bug? There have been quite a few updates since this started happening. (banshee crashing) I see that glib2 2.34.2-1 was updated and since I installed this, running Banshee from the shortcut seems to be working as expected? I could be completely off track but prior to this update Banshee was crashing and when I installed this update, it was the only item installed after I ran a -Syu. So far so good but I'm not holding my breath at this point! I'm hoping for the best! glib2 2.34.2-1 is required by at least 134 items so it appears to affect a vast number of things including dbus-glib, gstreamer, gstreamer0.10 etc. Banshee has played almost an entire album so far and has not crashed.... :-)

Afraid it back to square one and Banshee is still plowing away...
Comment by pictuga (pictuga) - Wednesday, 14 November 2012, 00:14 GMT
I have the same issue, details:
- gconf seems to be the problem for me, cause when it verbose-segfaults, log is all about gconf/dbus connection issues
- sometimes banshee's gconf connection exits silently, without having banshee crashing, but gconf connection is lost. Therefore if you check the "Settings" they are reset to defaults, in the UI, cause banshee can no longer access gconf-stored settings. But if you restart banshee, your own settings are still there. For me, for now, it's better when - for some reasons - gconf's connection is silently closed instead of segfault, cause I can still listen to music, but some features are then missing (import, settings). log looks like the one with lot's of info from gconf/dbus there https://bugs.archlinux.org/task/32390?getfile=9651
- my steps to reproduce: launch banshee, click "rescan library", when it finishes, banshee crashes OR gconf connection is lost (as described above). Sometimes hitting "Next" a couple of times also crashes banshee, but not all the time, while rescan is 100% of the time.
- I tried rebuilding gconf-sharp but it didn't change anything.

No improvement since 3.6.2. Same issue with blank user account.
Comment by John Piers (johnpiers) - Wednesday, 14 November 2012, 08:56 GMT
Not sure if this is the same as anyone else, errors seems to be slightly different now.
   banshee1 (0.4 KiB)
Comment by John Piers (johnpiers) - Wednesday, 14 November 2012, 09:00 GMT
Sorry double post!
   banshee1 (19.4 KiB)
Comment by John Piers (johnpiers) - Wednesday, 14 November 2012, 09:00 GMT
Not sure if this is the same as anyone else, errors seems to be slightly different now.

Below: I have seen this twice while trying to post a comment:

"Completely unexpected exception: Address in mailbox given [] does not comply with RFC 2822, 3.6.2.
This should never happend, please inform Flyspray Developers"
   banshee1 (19.4 KiB)
Comment by Marc (ttux) - Wednesday, 14 November 2012, 13:03 GMT
It started to crash again for me with segfault. I can play the first song then if I press to play next one, it crashes.

So I run it with --debug to see if I can find the reason but with --debug it doesn't crash...
Comment by Anthony Ruhier (Anthony25) - Wednesday, 14 November 2012, 22:52 GMT
It seems there is no more crash for me since the last upgrades of gnome packages.

By cons a little bug is still here : volume is always set to max when I start banshee.
Comment by pictuga (pictuga) - Wednesday, 14 November 2012, 23:26 GMT Comment by John Piers (johnpiers) - Thursday, 15 November 2012, 13:18 GMT
@Anthony, When it scans the music or video folder believe me it still crashes!! To get around this I've made an empty video folder and pointed Banshee to that. The first time that you open Banshee it crashes. The second time you open it, it scans the empty folder and seems to be OK. It appears to be happy with the existing music folder, I have not tried to add any new music yet to see what happens. Also still crashes the first time it goes from one song to the next.
Comment by Anthony Ruhier (Anthony25) - Thursday, 15 November 2012, 13:54 GMT
@pictuga : I have already done that, and it is not the pulseaudio volume which is set to max but only the banshee volume.

@johnpiers : You're right, I just tested the library scan and it makes banshee freezes...
Comment by John Piers (johnpiers) - Thursday, 15 November 2012, 14:02 GMT
Thanks for the confirmation Anthony, yes the volume issue is something else, quite correct, I had a look at the link and does not appear to have anything to do with what Banshee is doing. That said it looks like slowly but surely things are being resolved.
Comment by Nate G. (nateg3.14159) - Thursday, 15 November 2012, 20:00 GMT
Is anyone working on this?
It's still crashing for me. Fully up to date system.
Comment by Aaron (coldcontrol) - Friday, 16 November 2012, 18:29 GMT
Still crashing for me as well. Fully updated 64-bit system:

banshee 2.6.0-2
gst-plugins-base 1.0.2-1
gconf 3.2.5-3

Crash log attached.
Comment by John Piers (johnpiers) - Saturday, 17 November 2012, 01:48 GMT
Crashing more than ever before, very very disappointing indeed!
Comment by Cameron (aliencam) - Sunday, 18 November 2012, 00:16 GMT
I am having the same issues, I successfully used the volume tip in comment #102542 above. But am still getting dbus errors and segfaults.
https://bugs.archlinux.org/task/32390#comment102542
Comment by Nate G. (nateg3.14159) - Tuesday, 20 November 2012, 22:37 GMT
Still not working consistently. Trying to add music to the library causes a crash 100% of the time as well.
Comment by John Piers (johnpiers) - Wednesday, 21 November 2012, 09:02 GMT
Is anything actually being looked at? I don't want to sound impatient but it really does appear that nothing is being done to fix Banshee or whatever the problem is! If there was at least some feedback we at least would know if there is light at the end of the tunnel. Would be great to get some sort of answer. If I could fix the problem I would but don't have the skills to do it! Thanks.
Comment by Anthony Ruhier (Anthony25) - Wednesday, 21 November 2012, 19:11 GMT
I found 2 bugreports on the gnome bugzilla :

https://bugzilla.gnome.org/show_bug.cgi?id=688031
https://bugzilla.gnome.org/show_bug.cgi?id=688324

They are quite recent so I hope it will help to fix crashes...
Comment by Anthony Ruhier (Anthony25) - Wednesday, 21 November 2012, 23:15 GMT
My bug report on bugzilla.gnome.org : https://bugzilla.gnome.org/show_bug.cgi?id=688845
Comment by Kevin Knerr (barthel) - Thursday, 22 November 2012, 16:20 GMT
After reading the GNOME bugzilla reports, I created a mono 3.0.1 package. Banshee 2.4.1 continued working. I then upgraded to banshee-2.6.0-2 again. Banshee is again working again without crashing, although the GConf/DBUS message continue.

My PKGBUILD is attached. For simplicity I D/L'd mono.binfmt.d manually: https://projects.archlinux.org/svntogit/packages.git/plain/trunk/mono.binfmt.d?h=packages/mono

Hope this helps!
   PKGBUILD (1.6 KiB)
Comment by David López (David López) - Friday, 23 November 2012, 00:49 GMT
Thanks Kevin. This afternoon I've tried the mono-git in AUR, but the crashes still occur. I'll try with mono 3 from your PKGBUILD and I'll let you know
Comment by Marc (ttux) - Friday, 23 November 2012, 10:16 GMT
I've just tried with this PKGBUILD and so far so good. Thank you. I'll confirm in a few days as this is sometimes so inconsistent.
Comment by Anthony Ruhier (Anthony25) - Friday, 23 November 2012, 19:11 GMT
Many thanks barthel, I will test it and tell you in a few days if it fix the bug !

Edit : I had a few crash

process 2088: arguments to dbus_message_unref() were incorrect, assertion "message->generation == _dbus_current_generation" failed in file dbus-message.c line 1617.
This is normally a bug in some application using the D-Bus library.
D-Bus not built with -rdynamic so unable to print a backtrace
Stacktrace:


Native stacktrace:

Thread 0x7fd92fbe6700 may have been prematurely finalized
zsh: segmentation fault banshee
Comment by David López (David López) - Saturday, 24 November 2012, 10:10 GMT
Im afraid I can't see any difference with mono 3: frequent crashes when rescanning the library and ending songs
Comment by yvan (keskispace) - Sunday, 25 November 2012, 20:46 GMT
I've just tried with the patch I found here https://bugs.launchpad.net/ubuntu/+source/banshee/+bug/1048341
and it seems to be stable
Comment by pictuga (pictuga) - Sunday, 25 November 2012, 21:31 GMT Comment by yvan (keskispace) - Sunday, 25 November 2012, 21:41 GMT Comment by pictuga (pictuga) - Sunday, 25 November 2012, 21:53 GMT
Thanks a lot!
For those looking for patch alone (not debdiff) : https://bazaar.launchpad.net/~timo-jyrinki/gconf/ubuntu.support-s-to-as-migrations/view/head:/debian/patches/call-dbus_g_thread_init.patch

edit: stable indeed
edit: feels good to listen to music again :)
Comment by Anthony Ruhier (Anthony25) - Monday, 26 November 2012, 01:45 GMT
A banshee developer answers me on my bug report : https://bugzilla.gnome.org/show_bug.cgi?id=688845

He asks me to ask on the ubuntu bug report (on launchpad) what is the bug number of this Gconf bug. I asked on launchpad, but if anybody knows it, it would be great !
Thanks !
Comment by Sudhir Khanger (donniezazen) - Monday, 26 November 2012, 17:53 GMT
Can anyone see if this is the same bug http://pastebin.com/wcudsegT

Thanks.
Comment by David López (David López) - Monday, 26 November 2012, 21:27 GMT
I have great news. I didn't applied the patch, I've simply built gconf-ubuntu 3.2.5-5 from AUR, and all my problems are gone. Wish this works for you.
Comment by pictuga (pictuga) - Monday, 26 November 2012, 21:55 GMT
it makes sense since the patch that yvan found is from ubuntu, where it's already in use (ie. it's in gconf-ubuntu)
adding the given patch to the PKGBUILD solves the problem too, while staying closer to arch's gconf.

here's my source package : http://www.pictuga.com/fiche-835.html (click "Télécharger")
Comment by John Piers (johnpiers) - Tuesday, 27 November 2012, 08:34 GMT
@Pictuga thanks, I don't want to tempt fate but your solution seemed to do the trick, hope that it continues to do what it must! Thanks again.
Comment by Jonathan Dlouhy (oboedad55) - Tuesday, 27 November 2012, 18:09 GMT
Thanks for the patch, it's good to have Banshee working again!
Comment by Kevin Knerr (barthel) - Wednesday, 28 November 2012, 07:29 GMT
Just read the commentary in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=694340 -- have any of you experienced issues with other apps? (According to the thread, the more correct solution is to port GConf to GDBus.

OTOH, it looks like the API may be flawed--dbus_g_thread_init() may only be called once, per the API, but if it is merely a wrapper to dbus_threads_init_default() which may be called multiple times...
Comment by David López (David López) - Friday, 30 November 2012, 08:24 GMT
Kevin, I haven't noticed any issue with gconf-ubuntu from AUR
Comment by pictuga (pictuga) - Saturday, 01 December 2012, 11:09 GMT
it would be cool is packagers could include the given patch sometime, so that everybody can enjoy a working banshee...
and softwares like tomboy (C#) may also be concerned by the issue.
Comment by Luciano Ruete (luchano) - Saturday, 01 December 2012, 23:20 GMT
I've open a task agaisnt gconf package where the fix belongs: https://bugs.archlinux.org/task/32927

Also I've compiled gconf package with the fix and here is the direct link for a quick fix.

pacman -U https://dl.dropbox.com/u/37866716/gconf-3.2.5-3-x86_64.pkg.tar.xz


Comment by Anthony Ruhier (Anthony25) - Sunday, 02 December 2012, 11:53 GMT
A patch has been submitted for banshee : https://bugzilla.gnome.org/show_bug.cgi?id=688324#c17

I'm testing it right now, it seems working (I didn't applied the gconf patch).

Edit : it doesn't fix crashes, this patch is done to fix an other problem...
And thanks keskispace, the patch you posted is working great !
Comment by pictuga (pictuga) - Friday, 07 December 2012, 13:22 GMT
For those interested, I've put my package on AUR: https://aur.archlinux.org/packages/gconf-thread/
it's archlinux's gconf with the given patch.

Loading...