Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32343 - [gtk3] GtkTreeView draws incorrectly since 3.6.1-1

Attached to Project: Arch Linux
Opened by John Lindgren (jlindgren) - Wednesday, 31 October 2012, 22:51 GMT
Last edited by Evangelos Foutras (foutrelis) - Friday, 25 January 2013, 10:05 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ionut Biru (wonder)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:

Please look at the attached screencast, as it illustrates the problem better than words. When moving the mouse cursor over a GtkTreeView, rows below a certain point redraw themselves one row too high; that is, on top of the preceding row. In the screencast, the cutoff point is the sixth row. Notice how row five ("Bokyo Dream") and row six ("Tuesday Morning") both draw to the same location on the screen, while the very last row ("Fields of Athenry") is repeated twice. This is a regression in 3.6.1-1; downgrading to gtk3 3.4.4-1 fixes the problem.

Additional info:
* package version(s)

gtk3 3.6.1-1
audacious 3.3.2-1

Steps to reproduce:

Start Audacious with the GTK interface and some song files in the playlist. Move the mouse over the playlist.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Friday, 25 January 2013, 10:05 GMT
Reason for closing:  Fixed
Comment by Tehacjusz Flow (thc_flow) - Thursday, 01 November 2012, 21:51 GMT
Same errors on my OS.
GTK3 3.6.1-1 and ANY program using it, with ANY theme.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Thursday, 01 November 2012, 22:35 GMT
Thanks for reporting. Please report this bug upstream, to the gtk3 developers. Including a link to this bug in the upstream bug report, and the link to the upstream bug report here is recommended.
Comment by David Glanzman (limescout) - Saturday, 03 November 2012, 21:18 GMT
works fine for me, 3.6.1-1 and Gnome. My video demo is attached.
   out.ogv (1.9 MiB)
Comment by John Lindgren (jlindgren) - Sunday, 04 November 2012, 03:06 GMT
I've bisected the problem to this commit:
http://git.gnome.org/browse/gtk+/commit/?id=aaedc7b67fbe6d74fe75d2a4011777d794eeac60

David, I'm trying to think of what might be different between our systems. Have you tried using the default Raleigh theme or using a non-compositing window manager? Edit: Never mind, I tried using Adwaita and enabling compositing; neither made any difference.
Comment by David Glanzman (limescout) - Sunday, 04 November 2012, 18:29 GMT
If there's any more info about my system you'd like, I'd be happy to oblige.
Comment by John Lindgren (jlindgren) - Tuesday, 06 November 2012, 03:10 GMT
Here is a patch that works for me. I will submit it upstream for comment when I get a chance.
Comment by John Lindgren (jlindgren) - Tuesday, 06 November 2012, 23:45 GMT Comment by John Lindgren (jlindgren) - Monday, 26 November 2012, 02:07 GMT
Upstream has a fix here:
http://git.gnome.org/browse/gtk+/commit/?h=gtk-3-6&id=335ede0f83b7c4686c6414674ac8f335dee078bf

Please, can this be backported to the Arch package?
Comment by Christian Hesse (eworm) - Tuesday, 22 January 2013, 13:19 GMT
This should be fixed in gtk3 3.6.3-1 and later, no?
Comment by John Lindgren (jlindgren) - Tuesday, 22 January 2013, 22:49 GMT
It's fixed for me in 3.6.4-1.

Loading...