Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32325 - [gvfs] Duplicate entries for mounted volumes in file manager

Attached to Project: Arch Linux
Opened by Eric Fitts (erifk_) - Wednesday, 31 October 2012, 14:19 GMT
Last edited by Evangelos Foutras (foutrelis) - Tuesday, 06 November 2012, 11:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 24
Private No

Details

Description:

In thunar/pcmanfm with gfvs 1.14.0-1 duplicate entries for drives appear in the file manager sidebar. This is the case for usb drives, internal drives etc.

Note: this problem only started after the Oct 30 updates with gnome 3.6, udisks2.

Downgrading to gvfs solves the problem

Additional info:
* gvfs 1.14.0-1


Steps to reproduce:
mount any usb/internal/external drive and restart thunar/pfmanfm
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Tuesday, 06 November 2012, 11:51 GMT
Reason for closing:  Fixed
Additional comments about closing:  Upstream patch included in gvfs 1.14.1-1.
Comment by mehmet (nabukadnezar43) - Wednesday, 31 October 2012, 19:06 GMT
Happens on a clean install as well.
Comment by Barbu Paul - Gheorghe (paullik) - Wednesday, 31 October 2012, 19:27 GMT
Mehmet is right, same thing over here.
Comment by Jove Yu (JoveYu) - Thursday, 01 November 2012, 07:27 GMT
same as thunar
Comment by Matej Lach (MatejLach) - Thursday, 01 November 2012, 16:02 GMT
Same here, also happens when using nautilus and nemo (nautilus fork)
Comment by David G (Nethsu) - Thursday, 01 November 2012, 17:10 GMT
I just moved to a pure systemd setup and I'm experiencing the same issue:
pcmanfm 1.1.0-1
gvfs 1.14.0-1
Comment by Ionut Biru (wonder) - Thursday, 01 November 2012, 17:25 GMT
are you guys having static mount points in /etc/fstab?
Comment by David G (Nethsu) - Thursday, 01 November 2012, 17:33 GMT
In my case, I do not
Comment by Aleeex87 (aleeex87) - Thursday, 01 November 2012, 17:34 GMT
No I don't have static mounts, but the problem persists
Comment by Maksim Yakovlev (lampslave) - Thursday, 01 November 2012, 17:39 GMT
Confirm. Yes I have static mount points (mount properly) and unmounted partitions on 2nd hdd. These partitions are duplicated and can't de mounted. Reason: "Not authorized to perform operation". Looks like this: https://bbs.archlinux.org/viewtopic.php?id=129922
Comment by Barbu Paul - Gheorghe (paullik) - Thursday, 01 November 2012, 18:21 GMT
@IonuČ›:
Nope, no static mount points in fstab for those drives.
Comment by Ionut Biru (wonder) - Thursday, 01 November 2012, 19:12 GMT
can you guys do a udisksctl dump > dump and upload the output here?
Comment by Aleeex87 (aleeex87) - Thursday, 01 November 2012, 19:15 GMT
Here is my dumb from udisksctl. Hope it can help.
   dump (22.7 KiB)
Comment by Ionut Biru (wonder) - Thursday, 01 November 2012, 19:24 GMT
@Aleeex87 which partitions are doubled in the file manager?
Comment by Dhawan (asdha) - Thursday, 01 November 2012, 19:46 GMT
The ones that are doubled in my case are sdb1, sda3 and sda1. When I place a shortcut of the location of sdb1 (/media/sdb1) in the left pane in thunar, it's double entry disappears at next boot.
   dump (16.4 KiB)
Comment by Maksim Yakovlev (lampslave) - Thursday, 01 November 2012, 19:53 GMT
sdb1, sdb2 partitions are doubled.
   dump (21.2 KiB)
Comment by Christian (ubuntubang) - Thursday, 01 November 2012, 22:38 GMT
doubled are sda1, sda5, sdb1
   dump (28.4 KiB)
Comment by Barbu Paul - Gheorghe (paullik) - Friday, 02 November 2012, 06:04 GMT
My doubled partitions are fd0 (yet my computer doesn't have a floppy drive), sda1, sda8 and of course if I plug in an USB drive it is shown twice as well.
   dump (28 KiB)
Comment by Philip (nuc) - Friday, 02 November 2012, 21:16 GMT Comment by Serge M (Serioga) - Saturday, 03 November 2012, 00:06 GMT
Same problem here with thunar and pcmanfm.
Downgrading gvfs worked for me.
@Philip (nuc): So, is it gvfs or thunar/pcmanfm bug?
Comment by Philip (nuc) - Saturday, 03 November 2012, 00:29 GMT
@Serge: Dunno maby Thunar/PCManFM just need(ed) to be configured for the new version.
Comment by Christian (ubuntubang) - Saturday, 03 November 2012, 09:06 GMT
Thunar fixed this issue in master but PCManfm blames gvfs. odd
Is anyone of you guys experiencing this issue with nautilus?
Comment by Matej Lach (MatejLach) - Saturday, 03 November 2012, 11:14 GMT
@Christian (ubuntubang) - Yes, I am using nautilus and nemo (nautilus fork) and I have the same problem.
Comment by Ionut Biru (wonder) - Saturday, 03 November 2012, 11:21 GMT
Hard to believe that you are using nautilus 3.6. Nautilus doesn't have any issues only 3rd party file managers.
Comment by Matej Lach (MatejLach) - Saturday, 03 November 2012, 11:28 GMT
@Ionut Biru (wonder) - Well, right now I am using nemo (nautilus fork) as Nautilus 3.6 is unusable, but I had this problem in Nautilus immediately after upgrade as well, maybe its gone now, I don't know as I cannot stand nautilus 3.6
Comment by Ionut Biru (wonder) - Saturday, 03 November 2012, 11:33 GMT
this is not a bug in gvfs. please report upstream to the file managers bugtracker.
Comment by Matej Lach (MatejLach) - Saturday, 03 November 2012, 11:39 GMT
Probably, but to be honest it is hard to decide, as Thunar fixed this themselves (I have Thunar managing my desktop, but I dom't use it as my FM) and PCManFM is supposedly blaming gvfs.
Will look upstream.
Comment by Philip (nuc) - Monday, 05 November 2012, 21:58 GMT
  • Field changed: Percent Complete (100% → 0%)
It IS a GVFS bug. Here's what the Thunar dev said:
"It is a bug in gvfs (it emits a signal volumes-added + list_volumes, doubles the volumes). But easy to workaround."
Comment by Evangelos Foutras (foutrelis) - Monday, 05 November 2012, 22:00 GMT
I kind of agree with Philip; it looks like a bug in GVFS.

Now excuse me while I go add a workaround to xfdesktop >.>
Comment by Christian (ubuntubang) - Monday, 05 November 2012, 23:13 GMT Comment by Evangelos Foutras (foutrelis) - Tuesday, 06 November 2012, 00:56 GMT
Thanks for reporting it upstream Christian, I posted some additional information there. :)

Loading...