Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32321 - [iptables] state match in simple_firewall.rules

Attached to Project: Arch Linux
Opened by henning mueller (phects) - Wednesday, 31 October 2012, 11:23 GMT
Last edited by Andrea Scarpino (BaSh) - Thursday, 15 November 2012, 14:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

The "simple_firewall.rules" file from the iptables package uses the now obsolete state match. I attached the file changed to use the conntrack module.


Additional info:
* linux-3.6.4-1
* iptables-1.4.16.2-1


Steps to reproduce:

# iptables-restore < /etc/iptables/simple_firewall.rules
WARNING: The state match is obsolete. Use conntrack instead.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Thursday, 15 November 2012, 14:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  on trunk
Comment by Dolores (meskarune) - Monday, 12 November 2012, 23:44 GMT
I'm running into this issue:

systemctl status iptables.service
iptables.service - Packet Filtering Framework
Loaded: loaded (/usr/lib/systemd/system/iptables.service; enabled)
Active: failed (Result: exit-code) since Mon, 2012-11-12 18:40:29 EST; 12s ago
Process: 8648 ExecStart=/usr/sbin/iptables-restore /etc/iptables/iptables.rules (code=exited, status=2)
CGroup: name=systemd:/system/iptables.service

Nov 12 18:40:29 maharani iptables-restore[8648]: WARNING: The state match is obsolete. Use conntrack instead.
Nov 12 18:40:29 maharani iptables-restore[8648]: WARNING: The state match is obsolete. Use conntrack instead.
Nov 12 18:40:29 maharani iptables-restore[8648]: WARNING: The state match is obsolete. Use conntrack instead.
Nov 12 18:40:29 maharani iptables-restore[8648]: iptables-restore v1.4.16.2: no command specified
Nov 12 18:40:29 maharani iptables-restore[8648]: Error occurred at line: 33
Nov 12 18:40:29 maharani iptables-restore[8648]: Try `iptables-restore -h' or 'iptables-restore --help' for more information.
Nov 12 18:40:29 maharani systemd[1]: iptables.service: main process exited, code=exited, status=2/INVALIDARGUMENT
Nov 12 18:40:29 maharani systemd[1]: Failed to start Packet Filtering Framework.
Nov 12 18:40:29 maharani systemd[1]: Unit iptables.service entered failed state

Loading...