Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32309 - [systemd] quiet boot flashes grey background and is not really quiet

Attached to Project: Arch Linux
Opened by Kai Hendry (hendry) - Wednesday, 31 October 2012, 02:10 GMT
Last edited by Dave Reisner (falconindy) - Wednesday, 14 November 2012, 03:37 GMT
Task Type Support Request
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Tom Gundersen (tomegun)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: Tbh, I'm after an absolutely silent boot, completely black and smooth transitions right to X. Preferably not using Plymouth.

This video demonstrates my current boot with quiet: http://youtu.be/W6JisYARzho

It flashes grey whilst decompressing the kernel.

Additional info:
* systemd version 195-2


Steps to reproduce:
1) Add quiet to cmdlne via /boot/syslinux/syslinux.cfg whilst using systemd
APPEND root=/dev/sda1 ro 5 init=/usr/lib/systemd/systemd quiet
This task depends upon

Closed by  Dave Reisner (falconindy)
Wednesday, 14 November 2012, 03:37 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Worked around with vga=current as a kernel argument
Comment by Dave Reisner (falconindy) - Friday, 02 November 2012, 20:29 GMT
I'd suspect syslinux to be a "problem" before systemd. You can verify that it isn't systemd by adding a hook to your initramfs that runs the "clear" command.
Comment by Greg (dolby) - Friday, 02 November 2012, 23:27 GMT
This started happening here too when i updated to a 3.6 kernel. I dont remember if a systemd upgrade went along with it and sadly my pacman logs dont indicate (thats my own fault).
Comment by Dave Reisner (falconindy) - Thursday, 08 November 2012, 01:21 GMT
ping?
Comment by Kai Hendry (hendry) - Thursday, 08 November 2012, 03:04 GMT
pong! :) I didn't have time to figure out hooks in the initramfs https://wiki.archlinux.org/index.php/Mkinitcpio#HOOKS Dave.

I don't know where the problem is. Feel free to move it. I can't see myself ever using grub2 bloatware in favour of something lightweight like extlinux as a bootloader.

Either way, there should be a bug open to solve this "silent boot" issue which has long plagued the Linux desktop user.
Comment by Kai Hendry (hendry) - Wednesday, 14 November 2012, 03:36 GMT
The syslinux argument: vga=current

Solves the problem!

Loading...