Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32307 - [linux] kernel 3.6.4 doesn`t boot

Attached to Project: Arch Linux
Opened by Daniel Kozák (kozzi) - Tuesday, 30 October 2012, 21:13 GMT
Last edited by Dave Reisner (falconindy) - Thursday, 03 January 2013, 14:43 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 31
Private No

Details

Description:

after upgrading to 3.6.4 I am unable to boot, it shows Loading initrams or something like that, and than freeze


Steps to reproduce:
try to start pc :)
This task depends upon

Closed by  Dave Reisner (falconindy)
Thursday, 03 January 2013, 14:43 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed a while ago, reopened erroneously.
Comment by Christian (close2) - Wednesday, 31 October 2012, 15:43 GMT
I can confirm this.

My setup is:
core/grub-common 2.00-1
core/grub-bios 2.00-1

(Not uefi even though the partition is in GPT)

My partition is GPT.
Partitions:
(parted) print
Model: ATA OCZ-VERTEX3 (scsi)
Disk /dev/sda: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 119GB 119GB
2 119GB 119GB 537MB linux-swap(v1)
4 120GB 120GB 256MB grub bios_grub
3 120GB 120GB 256MB ext2 boot

sda1 is btrfs.

Only arguments/settings in mkinitcpio.conf are:
HOOKS="base udev autodetect pata scsi sata filesystems usbinput"

System just hangs after
Loading Initial ramdisk ...

adding debug options to grub show, that the ramdisk is found and started.
If I understand the debug output correctly is even shows, that the kernel recognizes the GPT partition. One of the last lines is something like "Closing hd0". Don't know if this is relevant.

WORKAROUND:
downgrade to 3.6.3-1

You should still have the old 3.6.3 package in your cache directory (if not, you deleted it and are on your own)
cd /var/cache/pacman/pkg/
pacman -U linux-3.6.3-1-x86_64.pkg.tar.xz

Hope that helps
Comment by Christian (close2) - Wednesday, 31 October 2012, 15:49 GMT
BTW linux-3.6.4-1-x86_64.pkg.tar.xz is no longer in testing!
Comment by Fred Richards (flrichar) - Wednesday, 31 October 2012, 18:02 GMT
There's a conversation going on in the forum:
https://bbs.archlinux.org/viewtopic.php?pid=1184874

Apparently if you have a recent AMD chip and >= 8GB of ram, this is an issue. Some have booted with a temporary kernel option of "mem=4G".
Comment by Christian (close2) - Wednesday, 31 October 2012, 18:15 GMT
>= 8GB and recent AMD chip is correct:
model name : AMD FX(tm)-8150 Eight-Core Processor

16GB RAM
Comment by Christian (close2) - Wednesday, 31 October 2012, 18:17 GMT
There is however no visible kernel panic!
Comment by Fred Richards (flrichar) - Wednesday, 31 October 2012, 18:28 GMT
It's quite similar to this bug, in that the error message is the same/similar.

https://bugs.archlinux.org/task/29351

Comment by tim (sudokode) - Wednesday, 31 October 2012, 19:13 GMT
Confirmed here as well on 3.6.4-1-ARCH and 3.6.4-1-ck

AMD FX-6100 with 8GB of memory
Comment by Culley Smith (CulleyS) - Wednesday, 31 October 2012, 20:30 GMT
Not sure if you need more info on this, but I had the same problem today. 16GB of ram, AMD FX 8120 processor 8-core processor. Adding mem=4G to my boot line allowed me to load the kernel and boot into Arch. Kernel v. 3.6.4.1.
Comment by Greg (dolby) - Wednesday, 31 October 2012, 20:48 GMT
Is this fixed in 3.6.5? Otherwise, a bugzilla.kernel.org link is missing...
Comment by Fred Richards (flrichar) - Wednesday, 31 October 2012, 21:18 GMT
If this is the same bug (and I'm not sure), but it may be fixed in 3.6.5 ...

https://lkml.org/lkml/2012/10/29/239

Comment by John (Chessmaster942) - Wednesday, 31 October 2012, 21:39 GMT
Just adding another record of this incident.

AMD A8-3850
8GB RAM

Adding mem=4G to kernel boot options seems to work.
Comment by Leonidas Spyropoulos (inglor) - Wednesday, 31 October 2012, 21:46 GMT
I confirm as well.
AMD FX 8120 with 8GB RAM.
Comment by adam (freeman) - Wednesday, 31 October 2012, 22:28 GMT
I can also confirm this.

AMD Phenom ii x4 965 with 8gb of ram.
Comment by Greg (dolby) - Wednesday, 31 October 2012, 22:50 GMT
PLEASE STOP CONFIRMING THIS. STICK TO ADDING YOUR VOTE ABOVE! THANKS!
Comment by Vasco Dias (diaz) - Thursday, 01 November 2012, 04:32 GMT
Asus laptop 1215b here, amd cpu. Using refind to boot, it just hangs when starting to access the initramfs.
Comment by Dave Dixon II (dbdii407) - Thursday, 01 November 2012, 05:15 GMT
AMD FX 8150 Eight-Core Processor with 16GB RAM. Having this issue as well. Downgraded until this is fixed.
Comment by Lawrence Woodman (LawrenceWoodman) - Thursday, 01 November 2012, 06:46 GMT
This isn't just with >= 8gb ram, my ultrabook has 4gb of ram and is affected. mem=4G did allow me in though to downgrade the package. My machine has an AMD E-450.
Comment by Leonidas Spyropoulos (inglor) - Thursday, 01 November 2012, 09:53 GMT
Shouldn't this bug be in Kernel category? and not Testing?
Comment by Martín Cigorraga (msx) - Thursday, 01 November 2012, 17:33 GMT
I can't confirm this issue, everything's working fine here.

Some data about my install:
.Kernel line flags: rootfstype=ext4 hpet=force i915.i915_enable_rc6=1 pcie_aspm=force i915.lvds_downclock=1 radeon.pcie_gen2=1 i915.semaphores=1 security=tomoyo resume=/dev/sda3 acpi_backlight=vendor i915.modeset=1 usbcore.autosuspend=1 radeon.agpmode=-1 ipv6.disable=1 apparmor=0 nmi_watchdog=0 libahci.ignore_sss=1 elevator=bfs
.systemd enabled
.detailed info here: http://i.imgur.com/Gaggy.png
Comment by Håkon Vågsether (hauk142) - Thursday, 01 November 2012, 18:28 GMT
Martín, this problem is only for users with AMD CPUs and 4 GB or more of RAM.
Comment by Spartan Roc (spartanroc) - Wednesday, 02 January 2013, 15:43 GMT
  • Field changed: Percent Complete (100% → 0%)
I have similar problem for both stock kernels 3.6.6 and 3.6.7. The last kernel worked for me was 3.4.4. Now I am stuck with lts-3.0 until the problem gets fixed.

my cpu: Intel(R) Core(TM)2 Duo CPU E8400
memory: 8GB
HOOKS="base udev autodetect pata scsi sata filesystems usbinput fsck"

the system is fully updated by pacman -Syu

Comment by Dave Reisner (falconindy) - Wednesday, 02 January 2013, 18:07 GMT
@spartonroc: Why would you request a reopen of this bug when the problem is specific to AMD processors with >=4GB of RAM and 3.6.4?
Comment by Spartan Roc (spartanroc) - Thursday, 03 January 2013, 14:28 GMT
@Dave: because whatever the fix is, it does not really fix the whole problem. What I found was that the problem also occurs to the intel cpus and not solved in the latest kernel.
Comment by Dave Reisner (falconindy) - Thursday, 03 January 2013, 14:42 GMT
1 bug, 1 bug report. Whatever you broke is not related to this one.

Loading...