Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#32275 - make cronie.service aware of /etc/conf.d/crond

Attached to Project: Arch Linux
Opened by Pierre Buard (Gilrain) - Monday, 29 October 2012, 10:51 GMT
Last edited by Gaetan Bisson (vesath) - Monday, 29 October 2012, 12:41 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Currently, cronie.service doesn't apply any arguments declared in /etc/conf.d/crond. Since the file exists, why not make it available through the service file?

Additional info:
* cronie 1.4.8-3

Add an optional EnvironmentFile with $CRONDARGS to the ExecStart line

ExecStart=/usr/sbin/crond -n $CRONDARGS
This task depends upon

Closed by  Gaetan Bisson (vesath)
Monday, 29 October 2012, 12:41 GMT
Reason for closing:  Not a bug
Additional comments about closing:  The systemd approach is for you to copy cronie.service from /usr/lib/systemd/system to /etc/systemd/system and modify it there to suit your needs if you are unhappy with the defaults.