Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32271 - [gummiboot-efi] black screen hang on boot

Attached to Project: Arch Linux
Opened by Dennis Anderson (tweezerhead) - Monday, 29 October 2012, 01:14 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 14 November 2012, 11:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After upgrading from gummitboot 6 to 7 all I get is a black screen with a cursor on it.. Before the upgrade I had a menu and could boot. I down graded back to gummiboot-efi-6 and it works again.

My partition layout is: /boot/efi/ gummiboot.efi vmlinuz-linux.efi initramfs-linux.img are here.
/boot/efi/loader/loader.conf
/boot/efi/loader/entries/arch.conf and arch-fallback.conf

/boot/efi/loader/entries/arch.conf
title Arch Linux
linux /vmlinuz-linux.efi
initrd /initramfs-linux.img
options root=LABEL=root ro pcie_aspm=force fbcon=scrollback:128k add_efi_memmap

ASUS p8Z68-v Pro mobo Corei7, AMI UEFI ver 3204

Thanks for the attention,
Dennis
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 14 November 2012, 11:34 GMT
Reason for closing:  Fixed
Comment by Keshav Amburay (the.ridikulus.rat) - Tuesday, 30 October 2012, 05:53 GMT
I think this issue is specific to Asus systems. Many other users (mostly Lenovo) have confirmed gummiboot-efi-7 working in their systems. Report this issue to the upstream author Kay Sievers at kay@vrfy.org .
Comment by Dennis Anderson (tweezerhead) - Tuesday, 30 October 2012, 11:49 GMT
Info forwarded to upstream (Kay Sievers ,kay@vrfy.org>)

Comment by Keshav Amburay (the.ridikulus.rat) - Tuesday, 30 October 2012, 16:14 GMT
There seems to be some issue with gummiboot when one entry filename is an extension of another entry filename. Can you try renaming /boot/efi/loader/entries/arch.conf to /boot/efi/loader/entries/arch-core.conf or something like that and also change "default arch" to "default arch-core" in /boot/efi/loader/loader.conf, and try again?
Comment by Dennis Anderson (tweezerhead) - Tuesday, 30 October 2012, 16:50 GMT
Kay sent a patch. The patch did not fix the problem. He then sent me the binary compiled on his system, which works.
So if installed for the repos or built on my system they fail.
Here is the patch
http://cgit.freedesktop.org/gummiboot/commit/?id=3086905eaaed65c681ce2b62b309b6c5c4d99a3a
Comment by Dennis Anderson (tweezerhead) - Tuesday, 30 October 2012, 17:01 GMT
Also I did try the renaming of the config files and it does not help.
Comment by Mika Fischer (mika.fischer) - Thursday, 01 November 2012, 15:37 GMT
I had the same issue with v7, but for me the current gummiboot git (which was released as v8) works.
Comment by Dennis Anderson (tweezerhead) - Friday, 02 November 2012, 09:53 GMT
With v8 I get a menu showing only EFI shell which I did not even create a config file for. My arch-core and arch-fallback are not in the menu. They only show with v6 or v7 compiled on Kay Sievers system.
Comment by Mika Fischer (mika.fischer) - Friday, 02 November 2012, 10:08 GMT
Yep, same issue here with v8. But I think that's a different issue.
Comment by Tobias Powalowski (tpowa) - Monday, 05 November 2012, 14:48 GMT
Status on v8?
Comment by Dennis Anderson (tweezerhead) - Tuesday, 06 November 2012, 16:31 GMT
v8 status. With shellx64.efi in the efi directory, and only arch config files in loader/entries all I get at boot is the EFI SHELL selection. It will boot the shell. If I remove the shellx64.efi binary. when I boot I get "loader/entries/*.conf needed". It then boots the next entry in efibootmgr boot order.

v6 and a v7 sent to me by the developer still work as expected.
Comment by Tobias Powalowski (tpowa) - Monday, 12 November 2012, 14:11 GMT
Should all be fine now with patched gnu-efi-libs and rebuild gummiboot package.
Comment by Mika Fischer (mika.fischer) - Monday, 12 November 2012, 20:23 GMT
I can confirm that all v8 versions "work" for me (package from extra, gummiboot-efi-git from AUR and self-compiled from git). With "work" I mean they do not immediately lock up the machine.

However, I still have the issue that no entries are present, so only the defaults can be chosen (EFI default loader, EFI shell, Windows bootloader). So I can't boot Arch with gummiboot, unfortunately.

I tried adding some debug Print()s, however everything I change makes the machine lock up immediately :/ Not sure what's the best way to debug this...

Loading...