Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32249 - [linux] 3.6.x - 3.9.x iwlwifi driver broken with Intel wireless cards

Attached to Project: Arch Linux
Opened by Jake Rooney (Minsc) - Saturday, 27 October 2012, 13:50 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 05 August 2013, 07:40 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:

On kernels 3.6.* (3.6.2-1 and 3.6.3-1 tested) the iwlwifi driver crashes when attempting to authenticate with an AP using WPA.

Wireless NIC: Intel Corporation Centrino Wireless-N 1000

This has been confirmed with other models, see: https://bbs.archlinux.org/viewtopic.php?pid=1176708

Disabling 11n in /etc/modprobe.d/modprobe.conf with:
options iwlwifi 11n_disable=1

Seems to create a temporary fix.

Additional info:
See klog.txt (kernel trace) and iwl.txt (iwlwifi driver errors)

Steps to reproduce:
Boot machine and attempt to authenticate with an AP using WPA
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 05 August 2013, 07:40 GMT
Reason for closing:  Fixed
Comment by Jake Rooney (Minsc) - Wednesday, 31 October 2012, 14:33 GMT
This still affects the latest kernel 3.6.4-1-ARCH.
Comment by Ruben Guerra (rugebiker) - Friday, 02 November 2012, 04:34 GMT
I can confirm this bug on kernel 3.6.4-1. I downgraded to 3.6.2-1 so I could temporary keep it working. Using an Intel WiFi Link 5100AGN.
Comment by Ruben Guerra (rugebiker) - Friday, 02 November 2012, 19:46 GMT
Also, for me isn't that the wireless crashes when trying to connecto using WPA, but since I turn on the computer, it just doesn't recognizes the wireless card. If I do "ifconfig" or "airmon-ng" the card doesn't appears there. But if I do "lspci" the card is there.
Comment by Alexander Straube (a-st) - Saturday, 03 November 2012, 11:56 GMT
I can confirm this bug too, running kernel 3.6.5-1-ARCH.

Hardware is:
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)
Subsystem: Intel Corporation Lenovo ThinkPad T61
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR+ <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 49
Region 0: Memory at df2fe000 (64-bit, non-prefetchable) [size=8K]
Capabilities: <access denied>
Kernel driver in use: iwl4965

Disabling 11n in /etc/modprobe.d/modprobe.conf with "options iwlwifi 11n_disable=1" didn't help at all.
Comment by Jake Rooney (Minsc) - Tuesday, 06 November 2012, 15:01 GMT
Kernel 3.6.6-1-ARCH seems to have fixed this for me, can anyone else confirm?
Comment by Francois Colas (fcolas) - Tuesday, 06 November 2012, 22:11 GMT
Doesnt' work for me, even with Kernel 3.6.6-1-ARCH.

My Wireless card : Intel WiFi Link 5100.
Comment by Rodrigue (rtk) - Wednesday, 07 November 2012, 01:41 GMT
Doesn't work for me either even with kernel 3.6.6-1-ARCH
My wifi card is Intel Wifi Link 5100
Comment by Rodrigue (rtk) - Wednesday, 07 November 2012, 02:40 GMT
Update: I got it to work. Among the things I did there was:
- activate mac address filtering on router
- uninstall netcfg with -sn options
- took wlan0 down with ifconfig because it kept staying busy even with the netcfg commands
- install network-manager
- set up a new wireless connection with wpa encryption

Maybe that can help somebody.
Comment by lee.Meng (leaveboy) - Monday, 12 November 2012, 17:33 GMT
doesn't work,too.
system info:
system:Linux LM 3.6.6-1-ARCH #1 SMP PREEMPT Mon Nov 5 11:57:22 CET 2012 x86_64 GNU/Linux
wlan:03:00.0 Network controller: Intel Corporation Centrino Wireless-N 2200 (rev c4)
Comment by Alexander Straube (a-st) - Monday, 12 November 2012, 18:31 GMT
For me it works fine now. (Using netcfg or networkmanager)

- netcfg-3.0-1
- networkmanager-0.9.6.4-1
- linux-3.6.6-1

03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)

Thank you very much!

Comment by Greg (dolby) - Saturday, 17 November 2012, 09:18 GMT
Is there anyone still having problems?
Comment by st.binder (nium) - Tuesday, 20 November 2012, 13:24 GMT
doesn't work with linux 3.6.6 and linux 3.6.7 from testing
from time to time network freezes, workaround 11n_disable=1 as before
hardware: intel wifi-link 1000 bgn
Comment by st.binder (nium) - Thursday, 29 November 2012, 14:31 GMT
since updating kernel to linux 3.6.8 there are no freezes anymore.
Comment by Ruben Guerra (rugebiker) - Wednesday, 02 January 2013, 15:40 GMT
  • Field changed: Percent Complete (100% → 0%)
I just tried with kernel 3.6.10 on arch x64 and I still have the problem =/
I downgraded back to kernel 3.6.2.1 in the meantime to make it work again.
Comment by Tobias Powalowski (tpowa) - Wednesday, 23 January 2013, 16:03 GMT
Status on 3.7.x?
Comment by st.binder (nium) - Thursday, 24 January 2013, 23:11 GMT
regression for linux 3.7.4, network is stable only with 11n_disable=1
hardware: intel wifi-link 1000 bgn
Comment by Travis Collins (erbrecht) - Friday, 25 January 2013, 00:06 GMT
*EDIT 1-25-2013* Correction, it's working for me with no workarounds. Switched from dhcpcd to dhclient.

Same issue:

kernel 3.7.4-1-ARCH

03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)
Subsystem: Intel Corporation Centrino Advanced-N 6205 AGN
Flags: bus master, fast devsel, latency 0, IRQ 48
Memory at f1500000 (64-bit, non-prefetchable) [size=8K]
Capabilities: [c8] Power Management version 3
Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [e0] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Device Serial Number 84-3a-4b-ff-ff-01-03-04
Kernel driver in use: iwlwifi
Comment by Tobias Powalowski (tpowa) - Wednesday, 27 February 2013, 11:17 GMT
Status on 3.8?
Comment by Justin Christian (justinmc) - Thursday, 07 March 2013, 17:39 GMT
Did a vanilla build of 3.8.2 last night. Bug still exists for me using Centrino Advanced-N 6235.

Also, isn't this the same bug as https://bugs.archlinux.org/task/31667 ?
Comment by Paolo Zaffino (paozaf) - Monday, 22 April 2013, 10:54 GMT
I think to have the same problem on a asus nv56 with a Intel Corporation Centrino Wireless-N 2230 (rev c4) wifi card and the 3.8.7-1 kernel version.
Comment by Paolo Zaffino (paozaf) - Monday, 29 April 2013, 20:50 GMT
Sorry, I didn't have this bug.
I had more of one service that tried to manage the wifi.
I solved with:
systemctl disable NetworkManager-wait-online.service
systemctl disable net-auto-wired.service
systemctl disable net-auto-wireless.service
Now all works fine.
Sorry again
Comment by Tobias Powalowski (tpowa) - Thursday, 23 May 2013, 19:44 GMT
Status on 3.9?
Comment by Joao Santiago (elmariachi) - Tuesday, 28 May 2013, 17:24 GMT
I was having this bug until this morning.. now I have no connection at all. both 3.9.3 and 3.9.4 dont connect. Some errors about RFKill. Amazing timing for the exam period... Ill try to use my other computer (the one im using now with linux and no problems, so its not the router) and upload some logs.
Comment by Joao Santiago (elmariachi) - Tuesday, 28 May 2013, 20:37 GMT
I was having this bug until this morning.. now I have no connection at all. both 3.9.3 and 3.9.4 dont connect. Some errors about RFKill. Amazing timing for the exam period... Ill try to use my other computer (the one im using now with linux and no problems, so its not the router) and upload some logs.
Comment by Joao Santiago (elmariachi) - Wednesday, 29 May 2013, 07:19 GMT
new error message. I had wireless for a while, and then it just "died". Now, after being off for 8h, I have wireless again, but I'm sure it will go down...
   sdf (8.6 KiB)
Comment by Tobias Powalowski (tpowa) - Tuesday, 30 July 2013, 10:22 GMT
Status on 3.10.x?
Comment by Danny Arnold (despairblue) - Monday, 05 August 2013, 07:26 GMT
Works for me.

Loading...