Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers

FS#32189 - ISO doesn't boot (hybrid-mode)

Attached to Project: Release Engineering
Opened by Tom (tAsk) - Tuesday, 23 October 2012, 19:49 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Sunday, 20 January 2013, 15:08 GMT
Task Type Bug Report
Category Hardware Issues
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 2012.10.06
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Additional info:
* All Arch ISOs on flash drives

Steps to reproduce:

I'm trying to install Arch on my Sony VAIO VGN-Z11 via USB-Flash drive.
1. I wrote the ISO with:
sudo dd if=Downloads/archlinux-2012.09.07-dual.iso of=/dev/sdc
2. Then I put the USB flash into my notebook and it sticks at the VAIO screen right befor any bootmanager is loaded.
3. The USB flash drives LED is blinking constantly.
4. When I remove the USB flash, the pre-installed bootloader on the hraddisk comes up

Further investigation:

Then I tried other Distro ISOs to find out if they have the same issues:

#1: sudo dd if=Downloads/ubuntu-gnome-12.10-desktop-i386.iso of=/dev/sdc
#2: sudo dd if=Downloads/clearos-community-6.3.0-i386.iso of=/dev/sdc
#3: sudo dd if=Downloads/GNOME-3.6.0.iso of=/dev/sdc
#4: sudo dd if=Downloads/openSUSE-12.2-GNOME-LiveCD-x86_64.iso of=/dev/sdc
#5: sudo dd if=Downloads/archlinux-2012.10.06-dual.iso of=/dev/sdc

I experienced the exact same pattern with the Gnome.ISO like with any Arch.ISO. So both show the same blinking LED effect.

#1 Worked well no issues :)
#2 Some other not related issues. It showed the boot manager. :)
#3 SAME PROB like with Arch!!! :(
#4 Worked well no issues :)
#5 SAME PROB like with Arch!!! :(

There must be something different how the ISOs are booting. Or in the case of Gnome.ISO there must be something similar. I asked in #archlinux for help. And met someone who had the same issues with his Sony Notebook. Maybe it's only related to Sony notebooks, but other distros work well, so I guess, we just have to adjust something to get the ISOs running again. Without fixing this issue it's impossible to install Arch from USB flash drive on some systems.


This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Sunday, 20 January 2013, 15:08 GMT
Reason for closing:  Upstream
Additional comments about closing:  Upstream: Bad firmware issue. Thanks for the feedback.
Comment by Gerardo Exequiel Pozzi (djgera) - Tuesday, 23 October 2012, 22:55 GMT
  • Field changed: Category (Arch Projects → Hardware Issues)
  • Field changed: Reported Version ( → 2012.10.06)
  • Field changed: Architecture (All → All)
Looks like a "broken firmware" that does not understand the isohybrid hack where start of fake partition offset is 0 (this is how isohybrid is configured for Arch Linux ISO and the same happens to GNOME.iso). To see this, execute fdisk -l image.iso ;)

Since using other offset than 0 cause more problems, this setting will be keep like now. So I can offer two solutions:

1) Do not use Hybrid-MBR method, instead do steps manually.
2) Use isohybrid method, but change partition offset, (you need to pass archisodevice=/dev/sdX, where X is your USB drive, since FS_LABEL will be broken)
Execute: -offset 1 archlinux-2012.10-1-archboot-dual.iso
Or -offset 1 /dev/sdX (where X is your USB-flash-drive where you dump ISO image.
Comment by Tom (tAsk) - Friday, 02 November 2012, 18:07 GMT
I solved the issue with isohybrid:

### Solution
1. sudo -offset 1 archlinux-2012.10.06-dual.iso
2. sudo dd if=archlinux-2012.10.06-dual.iso of=/dev/sdX
where X is your USB drive

Please add this to the Installation Wiki. Others had this problem, too. This should help them fixing it.
Comment by Justin Buser (JustinBuser) - Thursday, 17 January 2013, 02:16 GMT
How is it a "bad firmware" issue? I have the same issue on one of my machines, but only with Arch.

I went through a similar process as mentioned above, and tried several other net install and live cd distros, all of which worked.

Regardless of whether or not older bios versions have anything to do with the issue, the fact of the matter is that there is a CLEARLY A BETTER way to create images so that work.

To simply not care enough to bother fixing such a widespread problem, or at the very least acknowledge it's existence, seems pretty slovenly, especially considering the fact that Arch should arguably be the easiest distro to fix.
Comment by Justin Buser (JustinBuser) - Thursday, 17 January 2013, 06:18 GMT
I must say, I'm impressed that this was reopened. Perhaps there's hope yet :) As it so happens I looked into the issue a bit more after writing that and what I found makes me wonder why there haven't been more complaints recently. As it's currently being distributed the current ISO (2013.01.04 from will fail to boot via USB on certain machines, but not due to firmware, there a couple files with extraneous periods in the file names. Additionally it would be completely uninstallable on any 64bit machine as both the i686 and x86_64 ram disk images are incorrectly named as root_image_fs.sfs instead of root-image.fs.sfs which is what the installer looks for and obviously cannot find. The fact that it's STILL like this just goes to show that sometimes even though certain solutions may seem apparent, they still warrant at least cursory attention.
Comment by Justin Buser (JustinBuser) - Thursday, 17 January 2013, 06:24 GMT
Incidentally, when I say that the failure to boot via USB is not due to firmware I should qualify that statement by also saying that I haven't tested on more than a couple of machines. I have 2 machines that would not but the ISO via USB as it was, and some reorganization/renaming of files as well as some minor modifications to the syslinux config files were all that it took to get USB to work. I'd be happy to share those modifications should anyone like to go over them.
Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 20 January 2013, 15:08 GMT
>>there a couple files with extraneous periods in the file names.
@JustinBuser: you have extracted files from ISO with a program that does not understand Rock Ridge[#1] extensions (Windows(r) utility?), so plain ISO9660 names are read. Please use proper tools[#2], otherwise you will see all files suffixed with ;1 and "_" instead of "-". Anyway this bug report is unrelated to your problem (isohybrid firmware issue VS using incorrect tool for extracting files from ISO image)