Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32175 - [python2-sip] 4.14-2 breaks python2-pyqt functionality

Attached to Project: Arch Linux
Opened by Sergio (zeno979) - Tuesday, 23 October 2012, 07:34 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 24 October 2012, 11:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After upgrading python2-sip and sip to 4.14-2, python applications which makes use of python2-pyqt libraries stopped working.

Additional info:
Here's the output:
[sergio@leviathan ~]$ luma
Traceback (most recent call last):
File "/usr/bin/luma", line 18, in <module>
from qt import *
RuntimeError: the sip module implements API v9.0 but the qt module requires API v8.1


Steps to reproduce:
-Upgrade sip and python2-sip to version 4.14-2
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 24 October 2012, 11:52 GMT
Reason for closing:  Not a bug
Additional comments about closing:  python modules that use pyqt need to be rebuilt
Comment by Andrea Scarpino (BaSh) - Tuesday, 23 October 2012, 08:24 GMT
Did you try to rebuild luma?
Comment by Sergio (zeno979) - Tuesday, 23 October 2012, 10:01 GMT
I tried, build also fails:

[sergio@leviathan luma]$ makepkg -s
==> Making package: luma 2.4-5 (Tue Oct 23 11:58:50 CEST 2012)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
-> Found luma-2.4.tar.bz2
==> Validating source files with md5sums...
luma-2.4.tar.bz2 ... Passed
==> Extracting Sources...
-> Extracting luma-2.4.tar.bz2 with bsdtar
==> Removing existing pkg/ directory...
==> Entering fakeroot environment...
==> Starting build()...
Luma 2.4 (C) 2003-2006 Wido Depping

Check for preinstalled modules:

python-ldap is installed...
Installed version: 2.4.10
Minimum version: 2.0.1

Traceback (most recent call last):
File "install.py", line 234, in <module>
doImportCheck()
File "install.py", line 48, in doImportCheck
import qt
RuntimeError: the sip module implements API v9.0 but the qt module requires API v8.1
==> ERROR: A failure occurred in build().
Aborting...
Comment by Andrea Scarpino (BaSh) - Tuesday, 23 October 2012, 10:02 GMT
So, seems that luma doesn't support the new sip. Please report this upstream.
Comment by Sergio (zeno979) - Tuesday, 23 October 2012, 10:29 GMT
  • Field changed: Percent Complete (100% → 0%)
Not only luma is affected but all python script that makes use of this library

[sergio@leviathan ~]$ python2
Python 2.7.3 (default, Apr 24 2012, 00:00:54)
[GCC 4.7.0 20120414 (prerelease)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import qt
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
RuntimeError: the sip module implements API v9.0 but the qt module requires API v8.1
Comment by Andrea Scarpino (BaSh) - Tuesday, 23 October 2012, 10:33 GMT
Are you sure that is the right way? import PyQt4 works.
Comment by Vincent Gay (vgay) - Tuesday, 23 October 2012, 17:03 GMT
I have the same error with Frescobaldi (AUR).

import popplerqt4
RuntimeError: the sip module implements API v9.0 but the popplerqt4 module requires API v8.1
Comment by Andrea Scarpino (BaSh) - Wednesday, 24 October 2012, 07:02 GMT
@Vincent
rebuild python2-poppler-qt

$ python2 -c "import popplerqt4"
$
Comment by Vincent Gay (vgay) - Wednesday, 24 October 2012, 11:38 GMT
@Andrea
that does the trick. Thanks

Loading...