Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32152 - [ibus-pinyin,gnome] Gnome 3.6 breaks Chinese input

Attached to Project: Community Packages
Opened by Kerrick Staley (KerrickStaley) - Monday, 22 October 2012, 02:28 GMT
Last edited by Felix Yan (felixonmars) - Monday, 05 November 2012, 09:52 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

With Gnome 3.6, Chinese input (using the ibus-pinyin input method) is broken. I can enable/configure PinYin input, but when I switch to it, the keyboard acts as it does for English.

For example, if I type "nihao", it echoes that string as typed, instead of showing a menu and suggesting 你好.

The Dvorak input method works, so the problem seems specific to ibus-pinyin.
This task depends upon

Closed by  Felix Yan (felixonmars)
Monday, 05 November 2012, 09:52 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Dup of  FS#32440 
Comment by Kerrick Staley (KerrickStaley) - Monday, 22 October 2012, 02:31 GMT
Versions:
ibus 1.4.99.20121006-1
ibus-pinyin 1.4.0-1
gnome-shell 3.6.1-1
Comment by chaofeng (rainofchaos) - Friday, 26 October 2012, 01:48 GMT
I am using KDE and have this problem too.
Downgrading to ibus-1.4.2 in [community] do not solve the problem.
Comment by Kerrick Staley (KerrickStaley) - Tuesday, 30 October 2012, 10:06 GMT
I forgot to mention that I'm running [testing]. The issue is that the current version of ibus-pinyin is incompatible with the ibus in [testing].

A temporary fix is to install pyzy-git and ibus-pinyin-git from the AUR.

Daniel Griffiths (ghost1227) has stepped down as a package maintainer, but he's still the assigned maintainer of ibus-pinyin, so someone will have to take up maintainership of this package in his stead.
Comment by Udo Müller (i18nde) - Wednesday, 31 October 2012, 08:05 GMT
After Gnome 3.6 is now stable and ibus-1.4.99.20121006-2 is now it still does not work.
Comment by Felix Yan (felixonmars) - Friday, 02 November 2012, 15:30 GMT
There is an ibus-pinyin-1.4.99.20120808.tar.gz on the ibus project download page, could anyone try it?
Comment by chaofeng (rainofchaos) - Monday, 05 November 2012, 03:27 GMT
Rebuild ibus-pinyin in ABS solve the issue.
Add install ibus-pinyin-git fix it too.
Comment by Kerrick Staley (KerrickStaley) - Monday, 05 November 2012, 09:37 GMT
With these two issues:

https://bugs.archlinux.org/task/32440
https://code.google.com/p/ibus/issues/detail?id=1542

this issue is now redundant I think; it can be closed.

Loading...