Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32151 - [glu] should depend on mesa

Attached to Project: Arch Linux
Opened by Gaetan Bisson (vesath) - Monday, 22 October 2012, 01:57 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 23 October 2012, 12:13 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The file /usr/include/GL/glu.h from glu-9.0.0-1 reads "#include <GL/gl.h>"; given that the file /usr/include/GL/gl.h belongs to mesa-9.0-1, the latter should be added as a dependency of glu.

(Or maybe gl.h should be moved to libgl; I am not sure if that would make sense.)
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 23 October 2012, 12:13 GMT
Reason for closing:  Not a bug
Comment by Andreas Radke (AndyRTR) - Tuesday, 23 October 2012, 12:13 GMT
We add only runtime dependencies. The mesa header is only needed to build software that inludes the glu.h at compile time.

Check also:
[andyrtr@workstation64 tmp]$ grep Requires /usr/lib/pkgconfig/glu.pc
Requires: gl

So it's not a bug.

Loading...