Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#32117 - nvidia-utils-304.60 is broken by pango-1.32

Attached to Project: Arch Linux
Opened by david cheung (scruffidog) - Saturday, 20 October 2012, 14:43 GMT
Last edited by Ionut Biru (wonder) - Tuesday, 06 November 2012, 21:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 19
Private No


Description: (extra) nvidia-utils-304.60 is broken by (testing) pango-1.32.
nvidia-setting requires which is no longer provided in pango-1.32 but is present in (extra) pango-1.30

Additional info:

* package version(s):

* config and/or log files etc.

Steps to reproduce:
$ ldd /usr/bin/nvidia-settings (0x00007fffd8999000) => /usr/lib/ (0x00007fad02c71000) => /usr/lib/ (0x00007fad02a5e000) => /usr/lib/ (0x00007fad02764000) => /usr/lib/ (0x00007fad02560000) => /usr/lib/ (0x00007fad01f33000) => /usr/lib/ (0x00007fad01c81000) => /usr/lib/ (0x00007fad01a5d000) => /usr/lib/ (0x00007fad0183b000)
>>> => not found <<<<<< => /usr/lib/ (0x00007fad015ee000) => /usr/lib/ (0x00007fad013a0000) => /usr/lib/ (0x00007fad0119c000) => /usr/lib/ (0x00007fad00ea6000) => /usr/lib/ (0x00007fad00aff000) => /usr/lib/ (0x00007fad008e0000)
/lib64/ (0x00007fad02faa000) => /usr/lib/ (0x00007fad006d3000) => /usr/lib/ (0x00007fad004cc000) => /usr/lib/ (0x00007fad001ce000) => /usr/lib/ (0x00007facffe7b000) => /usr/lib/ (0x00007facffc66000) => /usr/lib/ (0x00007facffa2c000) => /usr/lib/ (0x00007facff821000) => /usr/lib/ (0x00007facff61e000) => /usr/lib/ (0x00007facff40f000) => /usr/lib/ (0x00007facff205000) => /usr/lib/ (0x00007facfeffb000) => /usr/lib/ (0x00007facfedf8000) => /usr/lib/ (0x00007facfebf4000) => /usr/lib/ (0x00007facfe9ec000) => /usr/lib/ (0x00007facfe7bf000) => /usr/lib/ (0x00007facfe5a3000) => /usr/lib/ (0x00007facfe3a1000) => /usr/lib/ (0x00007facfe143000) => /usr/lib/ (0x00007facfdf3b000) => /usr/lib/ (0x00007facfdd37000) => /usr/lib/ (0x00007facfdb31000) => /usr/lib/ (0x00007facfd8cd000) => /usr/lib/ (0x00007facfd62f000) => /usr/lib/ (0x00007facfd3a9000) => /usr/lib/ (0x00007facfd1a6000) => /usr/lib/ (0x00007facfcf9c000) => /usr/lib/ (0x00007facfcd86000) => /usr/lib/ (0x00007facfcb6f000) => /usr/lib/ (0x00007facfc945000) => /usr/lib/ (0x00007facfc703000) => /usr/lib/ (0x00007facfc38c000) => /usr/lib/ (0x00007facfb06c000) => /usr/lib/ (0x00007facfae5c000) => /usr/lib/ (0x00007facfab59000) => /usr/lib/ (0x00007facfa944000)

This task depends upon

Closed by  Ionut Biru (wonder)
Tuesday, 06 November 2012, 21:11 GMT
Reason for closing:  Fixed
Comment by Ionut Biru (wonder) - Saturday, 20 October 2012, 14:55 GMT
gtk2 is optionally, should i add pangocrap in optdepends as well?
Comment by Dave Reisner (falconindy) - Saturday, 20 October 2012, 15:56 GMT
Strictly speaking, the package deps for nvidia-settings alone are:


Yes, there's some transitively fulfilled deps here, if you're into that sort of thing. Though, it'd be nice if this "just worked".
Comment by Jan de Groot (JGC) - Friday, 26 October 2012, 13:30 GMT
nvidia-utils should (opt)depend on pangox-compat, the compatibility module that provides the deprecated lib now.
Comment by Adam Nielsen (Malvineous) - Saturday, 03 November 2012, 10:47 GMT
Just confirming that manually installing pangox-compat allows nvidia-settings to run. This is with nvidia-304.60-3

Without this I get:

$ nvidia-settings
nvidia-settings: error while loading shared libraries: cannot open shared object file: No such file or directory