Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32103 - [fftw] Add "--enable-openmp" to CONFIGURE flags.

Attached to Project: Arch Linux
Opened by Kevin Dodd (Jesin) - Friday, 19 October 2012, 21:20 GMT
Last edited by Ronald van Haren (pressh) - Monday, 31 March 2014, 20:19 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

The upstream FFTW project supplies two libraries for multithreaded computations: pthreads and openmp. They are stored in differently-named .a and .so files, so both options can be compiled into the same package with no problems. See http://www.fftw.org/fftw3_doc/Installation-and-Supported-Hardware_002fSoftware.html for a basic summary.

I tried compiling the fftw package from the ABS tree after replacing:

CONFIGURE="./configure F77=gfortran --prefix=/usr \
--enable-shared --enable-threads --enable-type-prefix"

with:

CONFIGURE="./configure F77=gfortran --prefix=/usr \
--enable-shared --enable-threads --enable-openmp --enable-type-prefix"

in the PKGBUILD, and it seems to have worked with no problems and without a significant size increase compared to compilation without that added flag.
   PKGBUILD (1.4 KiB)
This task depends upon

Closed by  Ronald van Haren (pressh)
Monday, 31 March 2014, 20:19 GMT
Reason for closing:  Implemented
Additional comments about closing:  fftw 3.3.4-1
Comment by جاك الفضة (jacksilver) - Friday, 14 February 2014, 10:24 GMT
I would like to use openmp too. It is worth nothing this option is completelt safe and independant from --enable-threads

From the documentation :

--enable-openmp: Like --enable-threads, but using OpenMP compiler directives in order to induce parallelism rather than spawning its own threads directly, and installing an ‘fftw3_omp’ library rather than an ‘fftw3_threads’ library (see Multi-threaded FFTW). You can use both --enable-openmp and --enable-threads since they compile/install libraries with different names. By default, the OpenMP routines are not compiled.

Loading...