Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32089 - [totem] Can't play h264 videos

Attached to Project: Arch Linux
Opened by Roberto Catini (robcat) - Friday, 19 October 2012, 15:05 GMT
Last edited by Ionut Biru (wonder) - Saturday, 20 October 2012, 06:43 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Steps to reproduce:
Try to play http://www.808.dk/pics/video/gizmo.mp4 with totem

The message "The playback of this movie requires a H.264 decoder plugin which is not installed." appears and the video is played without video output (only audio)

On stdout:
** Message: Missing plugin: gstreamer|1.0|totem|H.264 decoder|decoder-video/x-h264, stream-format=(string)avc, alignment=(string)au, level=(string)3, profile=(string)constrained-baseline, parsed=(boolean)true (H.264 decoder)

I've installed gstreamer, gst-plugins-{base,good,bad,ugly} and x264, and from the the error message and the wiki it is not clear what's missing.

The gstreamer packages are 1.0.1 from x64-testing.
This task depends upon

Closed by  Ionut Biru (wonder)
Saturday, 20 October 2012, 06:43 GMT
Reason for closing:  Not a bug
Comment by Ionut Biru (wonder) - Friday, 19 October 2012, 15:36 GMT
you have to install gst-libav
Comment by Roberto Catini (robcat) - Friday, 19 October 2012, 16:23 GMT
Thanks! So, it's not a bug.
In the past, I usually installed the group gstreamer0.10-plugins, while now I have to pick the various packages individually and I missed gst-libav.

Is a group similar to gstreamer0.10-plugins planned?
Comment by Ionut Biru (wonder) - Friday, 19 October 2012, 16:32 GMT
in the past you had to install gstreamer0.10-ffmpeg.
Comment by Greg (dolby) - Friday, 19 October 2012, 23:51 GMT
@robcat:  FS#32091 

Loading...