Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32062 - [sysvinit] halt doesn't shutdown system

Attached to Project: Arch Linux
Opened by Marcel Korpel (Marcel-) - Thursday, 18 October 2012, 14:08 GMT
Last edited by Dave Reisner (falconindy) - Thursday, 18 October 2012, 15:32 GMT
Task Type Support Request
Category Packages: Core
Status Closed
Assigned To Eric Belanger (Snowman)
Tom Gundersen (tomegun)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I fear this is an upstream bug, but just in case: after installing systemd according to the wiki the system freezes on the shutdown message instead of turning off the computer. No error message is printed. A reboot works as expected.

This is not related to  FS#31938 , downgrading to linux 3.5.6-1 didn't this issue; after reinstalling sysvinit 2.88-9 the system shuts down fine.

Additional info:
* systemd 194-3
This task depends upon

Closed by  Dave Reisner (falconindy)
Thursday, 18 October 2012, 15:32 GMT
Reason for closing:  Not a bug
Comment by Dave Reisner (falconindy) - Thursday, 18 October 2012, 14:15 GMT
shutdown how? this report is painfully lacking in detail.
Comment by Marcel Korpel (Marcel-) - Thursday, 18 October 2012, 14:49 GMT
I'm sorry. Using sudo halt. All regular messages are printed (e.g. unmounting), no errors whatsoever.
Comment by Tobias Powalowski (tpowa) - Thursday, 18 October 2012, 14:54 GMT
try poweroff instead, halt can lead to such things.
Comment by Marcel Korpel (Marcel-) - Thursday, 18 October 2012, 15:10 GMT
Indeed, that solved it. So this is a bug in shutdown?
Comment by Dave Reisner (falconindy) - Thursday, 18 October 2012, 15:32 GMT
You're not even using shutdown. This is the intended behavior of halt. It's halt. Not poweroff.

Loading...