Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32049 - [networkmanager-dispatcher-ntpd] should not use SetNTP, enables ntpd.service

Attached to Project: Community Packages
Opened by Frank Vanderham (twelveeighty) - Thursday, 18 October 2012, 04:02 GMT
Last edited by Jelle van der Waa (jelly) - Thursday, 13 December 2012, 15:42 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jelle van der Waa (jelly)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
When using this package with systemd, the ntpd.service gets re-enabled every time a connection is made and therefore this script is called. This script should only *start* ntpd.service, not *enable* it.

When the ntpd.service is enabled, the next reboot it will get automatically started as part of the network systemd target, which is therefore before NetworkManager has a connection (in case of a Wifi connection, for example). This defeats the purpose of this dispatcher script.

Originally, I thought this was an issue with the SetNTP API, so I filed a bug there (https://bugs.freedesktop.org/show_bug.cgi?id=55938). However, this was closed as being "misuse of the SetNTP API". SetNTP is considered to be doing its job and should both enable and start the service.

Is there a reason why we cannot simply call "systemctl start ntpd.service" and "systemctl stop ntpd.service" upon connection and disconnection?

Additional info:
* package version: 1.0-4


Steps to reproduce:
- Disable the ntpd.service via "systemctl disable ntpd.service"
- Reboot, making sure no network connection can be established automatically
- Observe that the ntpd.service is not started
- Make a connection, this triggers the call to this dispatch script
- Reboot, again making sure no network connection is established automatically
- Observe that the ntpd.service is now started, which should not happen, since there is no connection
- Also observe that the ntpd.service is enabled, even though it was disabled in the first step
This task depends upon

Closed by  Jelle van der Waa (jelly)
Thursday, 13 December 2012, 15:42 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in the new version

Loading...