Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#32047 - [xorg-server, gnome-shell] disables many hotkeys and shortcut keys

Attached to Project: Arch Linux
Opened by Justin Sabelko (jbirdjavi) - Thursday, 18 October 2012, 01:33 GMT
Last edited by Jan de Groot (JGC) - Thursday, 18 October 2012, 22:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Ionut Biru (wonder)
Jan Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 16
Private No



This is related to and all its duplicates (that have been closed so that I can't comment on them, therefore I'm opening a new task to add this additional information).

There is an open bug in Gnome about this (, but their developers have questioned how xorg-server was compiled for arch. Namely comment #16:

"(In reply to comment #14)
> I have the same arch linux environment and included gnome-settings-daemon
> --debug in my gnome-session (with gnome-session-properties). Now i get debug
> messages in .xsession-errors:
> (gnome-settings-daemon:10144): media-keys-plugin-DEBUG: No Xinput2 support,
> disabling plugin

This sounds very much like an X server bug, which is why it broke after
upgrade. Maybe the Arch people accidentally compiled it without XInput2

I'm wondering if there's anything to what the Gnome developer has mentioned here, which is why I'm opening this new task. Feel free to mark as duplicate if necessary.

Additional info:
* xorg-server 1.13.0-2

Steps to reproduce:
Using vanilla Gnome 3.4, upgrade to xorg-server 1.13.0-2 and try any hotkeys. Seems to be affecting many people, including myself. See the following threads in addition to the links above:
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 18 October 2012, 22:37 GMT
Reason for closing:  Won't fix
Additional comments about closing:  GNOME 3.6 is in testing, should move to extra pretty soon.
Comment by Justin Sabelko (jbirdjavi) - Thursday, 18 October 2012, 16:19 GMT
Judging by the further comments in the Gnome bug tracker, it looks like this patch would fix the issue:

The gnome-settings-daemon 3.4.2 release doesn't support XInput 2.2, which was fixed in the above commit.
Comment by Ionut Biru (wonder) - Thursday, 18 October 2012, 16:41 GMT
we won't fix this in 3.4.2 since we have 3.6 in gnome-unstable soon to be moved in testing/extra.
Comment by Justin Sabelko (jbirdjavi) - Thursday, 18 October 2012, 16:47 GMT
Good to know. Thanks Ionut.
Comment by Vasily Khoruzhick (anarsoul) - Thursday, 18 October 2012, 18:18 GMT
There's src package with necessary patches:
Can anyone from gnome package maintainers get it into extra repo? I'm pretty sure it's matter of few hours, even if gnome-3.6 will come in few days it's much faster to get fixed 3.4.2 package.