Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32040 - [onboard] segfaults

Attached to Project: Community Packages
Opened by David López (David López) - Wednesday, 17 October 2012, 19:46 GMT
Last edited by György Balló (City-busz) - Thursday, 18 October 2012, 21:25 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To György Balló (City-busz)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: onboard 0.98.1-1 doesn't work at all. when I execute onboard I receive a cryptic error message:

[1] 1274 segmentation fault (core dumped) onboard

I've used gdb to debug the problem: http://pastebin.com/xXgCxSX1

I've been using onboard in a tablet without problem for a long time. The segmentation fault appears after this update, maybe there's a conflict between onboard 0.98.1-1 and some of these packages:

[2012-10-17 14:40] removed python-mechanize (0.2.5-2)
[2012-10-17 14:40] removed python-imaging (1.1.7-4)
[2012-10-17 14:40] removed python-notify (0.1.1-11)
[2012-10-17 14:40] removed python-simplejson (2.6.1-1)
[2012-10-17 14:40] upgraded bzr (2.5.1-1 -> 2.5.1-2)
[2012-10-17 14:40] upgraded python2-cssutils (0.9.9-2 -> 0.9.9-3)
[2012-10-17 14:40] upgraded python2-cherrypy (3.2.2-1 -> 3.2.2-2)
[2012-10-17 14:40] installed python2-mechanize (0.2.5-3)
[2012-10-17 14:40] upgraded python2-lxml (2.3.5-1 -> 3.0-1)
[2012-10-17 14:40] installed python2-imaging (1.1.7-5)
[2012-10-17 14:40] upgraded sip (4.13.3-2 -> 4.14-2)
[2012-10-17 14:40] upgraded python2-sip (4.13.3-2 -> 4.14-2)
[2012-10-17 14:40] upgraded python-dbus-common (1.1.1-1 -> 1.1.1-2)
[2012-10-17 14:40] upgraded python2-dbus (1.1.1-1 -> 1.1.1-2)
[2012-10-17 14:40] upgraded pyqt-common (4.9.4-2 -> 4.9.5-2)
[2012-10-17 14:40] upgraded python2-pyqt (4.9.4-2 -> 4.9.5-2)
[2012-10-17 14:40] upgraded python2-psutil (0.6.1-1 -> 0.6.1-2)
[2012-10-17 14:40] upgraded calibre (0.9.2-1 -> 0.9.2-2)
[2012-10-17 14:40] upgraded hplip (3.12.10.a-2 -> 3.12.10.a-3)
[2012-10-17 14:40] upgraded python2-xdg (0.23-1 -> 0.23-2)
[2012-10-17 14:40] installed python2-notify (0.1.1-12)
[2012-10-17 14:40] upgraded ibus (1.4.2-1 -> 1.4.2-2)
[2012-10-17 14:40] upgraded pygobject-devel (3.2.2-1 -> 3.2.2-2)
[2012-10-17 14:40] upgraded pygobject2-devel (2.28.6-6 -> 2.28.6-7)
[2012-10-17 14:40] upgraded python (3.2.3-3 -> 3.3.0-1)
[2012-10-17 14:40] upgraded python-cairo (1.10.0-1 -> 1.10.0-2)
[2012-10-17 14:40] upgraded python-dbus (1.1.1-1 -> 1.1.1-2)
[2012-10-17 14:40] upgraded python-distutils-extra (2.32-1 -> 2.37-1)
[2012-10-17 14:40] upgraded python-gobject (3.2.2-1 -> 3.2.2-2)
[2012-10-17 14:40] upgraded python-virtkey (0.61.0-1 -> 0.61.0-2)
[2012-10-17 14:40] upgraded python2-crypto (2.6-2 -> 2.6-3)
[2012-10-17 14:40] upgraded python2-distribute (0.6.28-1 -> 0.6.28-3)
[2012-10-17 14:40] upgraded python2-distutils-extra (2.32-1 -> 2.37-1)
[2012-10-17 14:40] upgraded python2-gobject (3.2.2-1 -> 3.2.2-2)
[2012-10-17 14:40] upgraded python2-gobject2 (2.28.6-6 -> 2.28.6-7)
[2012-10-17 14:40] upgraded python2-httplib2 (0.7.4-1 -> 0.7.6-1)
[2012-10-17 14:40] upgraded python2-pyinotify (0.9.3-2 -> 0.9.3-3)
[2012-10-17 14:40] upgraded python2-pyopenssl (0.13-1 -> 0.13-2)
[2012-10-17 14:40] upgraded python2-virtkey (0.61.0-1 -> 0.61.0-2)
[2012-10-17 14:40] upgraded python2-zope-interface (3.8.0-1 -> 4.0.1-1)
[2012-10-17 14:40] upgraded system-config-printer-common (1.3.11-1 -> 1.3.11-2)
[2012-10-17 14:40] upgraded system-config-printer-gnome (1.3.11-1 -> 1.3.11-2)
This task depends upon

Closed by  György Balló (City-busz)
Thursday, 18 October 2012, 21:25 GMT
Reason for closing:  Duplicate
Additional comments about closing:  of  FS#32034  . Python 3.3 compatibility fix was added in release 0.98.1-2
Comment by Greg (dolby) - Thursday, 18 October 2012, 09:50 GMT
It would have been more helpful to post the upstream bug report here too instead of just a forum thread.
https://bugs.launchpad.net/onboard/+bug/1067797
Comment by David López (David López) - Thursday, 18 October 2012, 10:23 GMT
Sorry Greg, I missed it. As you saw, I opened https://bugs.launchpad.net/onboard/+bug/1067797

I've downgraded python-3.3.0 to 3.2.3, and python-cairo-1.10.0-2, python-dbus-1.1.1-2, python-gobject-3.2.2-2 and python-virtkey-0.61.0-2 to previous *-1 packages and onboard has revived. Maybe some of that packages cause the problems, or maybe onboard is not ready yet to python 3.3.

If I discover anything relevant I'll not forget to post it here, in launchpad and in the arch forum.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Thursday, 18 October 2012, 14:54 GMT
Thanks for reporting and for including both debug information fro gdb and a link to the upstream bug report.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Thursday, 18 October 2012, 14:57 GMT
Forum thread, mentioned by Ethan Schoonover in duplicate bug report: https://bbs.archlinux.org/viewtopic.php?id=150856
Comment by György Balló (City-busz) - Thursday, 18 October 2012, 16:09 GMT
The segfault is caused by python-gobject: https://bugs.archlinux.org/task/32034
It's fixed in pygobject 3.4, but onboard still fails to run as I mentioned in the upstream bugreport.

I'll rebuild onboard to use python2 until upstream makes it compatible with python 3.3.
Comment by György Balló (City-busz) - Thursday, 18 October 2012, 21:22 GMT
Partially fixed in onboard-0.98.1-2.

I applied a compatibility fix for python 3.3, but currently you need to install python-gobject 3.4.1.1-1 from the [testing] repo to use Onboard.

I'm closing this task, because the crash is caused by python-gobject: https://bugs.archlinux.org/task/32034

Loading...