Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32004 - [curl][git] curl 7.28 breaks git http/https transport

Attached to Project: Arch Linux
Opened by Konstantin Gribov (gross) - Tuesday, 16 October 2012, 05:38 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Saturday, 17 November 2012, 16:19 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Dan McGee (toofishes)
Dave Reisner (falconindy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
New curl version (7.28) breaks git http/https transport.

git clone/push falls with "error: RPC failed; result=22, HTTP code = 401" on http/https repo with http authentication.
As I see in git logs (when started with GIT_CURL_VERBOSE=1) it doesn't sends Authorization header on POST.

With curl 7.27 all works fine.

Additional info:
* git 1.7.7.7 till 1.7.12.3
* curl 7.28

Steps to reproduce:
git clone/push http/https repo with auth. It will fail with "error: RPC failed; result=22, HTTP code = 401".
Fails on second POST request because of absence of Authorization HTTP header.
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Saturday, 17 November 2012, 16:19 GMT
Reason for closing:  Upstream
Additional comments about closing:  7.28.1 is planned for release on 11/20, and will only contain bugfixes (including this one).
Comment by Konstantin Gribov (gross) - Tuesday, 16 October 2012, 05:49 GMT Comment by Dave Reisner (falconindy) - Tuesday, 16 October 2012, 07:18 GMT
Hrmm... there was a fix for this that applied strictly to gnu-tls, but we build against openssl...

https://github.com/bagder/curl/commit/1a02e84589efb3f8717d50bdc78d3f369b799198
Comment by Dave Reisner (falconindy) - Tuesday, 16 October 2012, 07:37 GMT
Ah right, caused by:

https://github.com/bagder/curl/commit/ce8311c7e49eca93c136b58efa6763853541ec97

It's known upstream, there will be a fix soon enough (and perhaps a 7.28.1).
Comment by Dave Reisner (falconindy) - Thursday, 08 November 2012, 15:19 GMT
7.28.1 is planned for release on 11/20, and will only contain bugfixes (including this one).

Loading...