Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31959 - [xorg-server] 1.13.0 multiscreen mouse "loops" on primary display

Attached to Project: Arch Linux
Opened by Tom Kuther (teekay) - Sunday, 14 October 2012, 21:21 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 19 October 2012, 14:00 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
Since the update to xorg-server-1.13.0 my mouse is stuck on the primary display. I use separate X screens, left & right. When I move the mous to the right border of the left screen, it jumps to the left border of the left screen.

Might be nvidia blob related. There are other reports on f.g.o: http://forums.gentoo.org/viewtopic-p-7163594.html - so not arch related either.

Additional info:
* nvidia 304.51
* absolutely nothing special in the logs

Steps to reproduce:
1. update xorg-server from 1.12.4 to 1.13.0
2. use seperate x screens, xinerama or twinview
3. maybe use nvidia blob drivers
4. (try to) move mouse from one screen to the other
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 19 October 2012, 14:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.13.0-3 in testing with patch added
Comment by TuX (TuxLyn) - Monday, 15 October 2012, 00:09 GMT
I have the same issue with seperate X screens and nvidia. I'm using nvidia 304.51-3 and xorg-server 1.13.0-2. But Xinerama mode seems to work fine for me. But it takes more CPU power for some reason, because I can hear my fans spin more often and its slower overall compared to seperate x screens. Well at least something works this time, until the fix =)
Comment by david (Lord David III.) - Monday, 15 October 2012, 07:43 GMT
The same problem by me after update xorg to 1.13.0-2 with xf86-video-ati 1:6.14.6-2.
Comment by Tom Kuther (teekay) - Monday, 15 October 2012, 08:04 GMT
To sum up user reports on bbs.archlinux.org and other forums, it only affects separate X screen setups, not Xinerama or TwinView. Not directly related to nvidia either.
Comment by Tom Kuther (teekay) - Monday, 15 October 2012, 08:31 GMT Comment by Adam Ziegler (MrBond) - Monday, 15 October 2012, 21:50 GMT
Confirming same symptoms and packages as original report - using a slightly more complicated screen setup:

4 monitors, configured as 2x pairs with TwinView, each TwinView pair as a separate X screen. Mouse travel between screens was perfect before upgrade.

Downgrading xorg-server, xorg-server-common, xorg-server-devel, and xf86-input-evdev to pre-1.13 versions restores expected behavior. As in OP, nothing notable in the logs.
Comment by Andreas Radke (AndyRTR) - Tuesday, 16 October 2012, 15:48 GMT
CC'ed to the bug.
Comment by Bill Seremetis (bserem) - Wednesday, 17 October 2012, 16:06 GMT
Also happens with ati-catalyst. You have already figured that of course!

Took me a while to find out it was an X issue
Comment by Till Matthiesen (high.entropy) - Thursday, 18 October 2012, 14:50 GMT Comment by Max (archerseven) - Thursday, 18 October 2012, 19:36 GMT
I just tested that patch, and it works on my previously broken tri-monitor setup. Thanks for the information.
Comment by Bill Seremetis (bserem) - Thursday, 18 October 2012, 19:53 GMT
Stupid question:
I need to build a patched xorg-server from ABS, right?
Comment by Max (archerseven) - Thursday, 18 October 2012, 19:56 GMT
Yes. I'll attach the modified PKGBUILD and patch I used, in case you find it useful.
Comment by Bill Seremetis (bserem) - Thursday, 18 October 2012, 20:26 GMT
Thank you Max,
patch and PKBUILD work fine on my dual-head (with rotation) setup.

Shall I comment the success upstream?
Comment by Adam Ziegler (MrBond) - Thursday, 18 October 2012, 23:14 GMT
Patch with PKGBUILD provided by Max also works for me. Thanks much!

Loading...