Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31956 - [mesa] KWIN Gles support broken after latest X server/mesa upgrade

Attached to Project: Arch Linux
Opened by Flat Eric (flateric) - Sunday, 14 October 2012, 15:56 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Saturday, 17 November 2012, 18:48 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:
latest upgrade X server/libgles/mesa packages broke kwin support for gles (kwin_gles). Desktop with "kwin_gles" is unusable (flickering, very slow, terminal don't show characters...) Switch to kwin (kwin --replace) with composititng type opengl or XRender solve this problem.

After downgrade ati-dri, libegl, libgbm, libgl, libgles kwin_gles is running, but compositing type OpenGL not work only XRender is usable.

Maybe it's KDE bug, sorry if this isn't rigt place for reporting.
Forum: https://bbs.archlinux.org/viewtopic.php?id=150599

GPU: ATI x1400 driver: radeon
KDE: 4.9.2

Additional info:
* package version(s)
ati-dri, libegl, libgbm, libgl, libgles: 9.0-1

Steps to reproduce:
Update system and run in KDE: kwin_gles --replace
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Saturday, 17 November 2012, 18:48 GMT
Reason for closing:  Fixed
Comment by George (gh403) - Sunday, 14 October 2012, 18:45 GMT
I can confirm that the problem also exists with Intel Ivy Bridge graphics using intel-dri 9.0-1 and libgl 9.0-1 and plain kwin. There are rendering artifacts and performance is generally awful.
With compositing off, everything looks fine, of course.

As an example of the kind of performance hit, I get around 60 fps using glxspheres with packages versions 8.x, and never more than 28 fps with versions 9.0. The artifacts look like the attachment.
Comment by Javier Viñal (fjvinal) - Sunday, 14 October 2012, 19:32 GMT
I can confirm the same issue with an ATI card. The problem does not happens using Xrender instead of OpenGl for desktop effects.
Comment by Andras Kangli (bandita00) - Sunday, 14 October 2012, 20:20 GMT
I can confirm this with an nvidia card, nouveau driver.
Comment by Martín Cigorraga (msx) - Sunday, 14 October 2012, 20:42 GMT
Alongside suffering all kind of performance lost with both Intel and ATi (Radeon) graphics I'm having all sorts of funny artifacts here.
Comment by Andrea Scarpino (BaSh) - Monday, 15 October 2012, 07:07 GMT Comment by daimonion (demon) - Tuesday, 23 October 2012, 14:21 GMT
Updating mesa to git seems to solve these problems. At least for me.
Comment by George (gh403) - Tuesday, 23 October 2012, 14:43 GMT
Pity we'll have to wait a few months for the git code to hit a release.

Are you using AUR? If so, which package?
Comment by daimonion (demon) - Tuesday, 23 October 2012, 15:02 GMT
No, I use custom compiled packages:
https://pastee.org/gztge
(similar to Arch's default, just a bit modified).
Comment by Martín Cigorraga (msx) - Wednesday, 24 October 2012, 00:57 GMT
Thanks for sharing it Mladen.
Using your customized package I made KWin GLES work although with a hiccup: good old KWin toggles unusable (exceedingly slow).
Comment by Jochen (Parzival) - Friday, 26 October 2012, 06:33 GMT
Hello,

marking the severity low on this bug really is a laugh in the face of everyone affected. I manually have to downgrade to Mesa 8.0 after every sync because of artifacts and sluggish window behaviour. I wouldn't call this stable!

System: Intel HD4000, KDE 4.9.2, KWin
Comment by Andrea Scarpino (BaSh) - Friday, 26 October 2012, 06:40 GMT
Severity is low as we cannot do anything about this. This is a mesa bug.
Comment by Greg (dolby) - Friday, 26 October 2012, 06:42 GMT
The marked severity of this bug in the Archlinux bug tracker is of minor importance.
Its how the original reporter chose (?) to open his bug report, and the default setting in flyspray.
If you want to blame someone for this, blame him. But please dont make it a matter of high importance.

If you really care about solving this contribute here: https://bugs.kde.org/show_bug.cgi?id=308385 and here: https://bugs.freedesktop.org/show_bug.cgi?id=55998
This bug wont fix itself and the Archlinux developers wont be fixing it for you unless upstream does first.
Comment by Jochen (Parzival) - Friday, 26 October 2012, 06:58 GMT
I don't blame anyone for this. Though it seems that I didn't state clearly enough that downgrading to Mesa 8.x solves the problem. Can Mesa 9.0-1 really be considered stable?
Comment by Andrea Scarpino (BaSh) - Friday, 26 October 2012, 07:24 GMT
This isn't the right place to consider mesa stable or not. The mesa devs released it as 'stable' so report your thoughts to their ML.
Comment by Martín Cigorraga (msx) - Friday, 26 October 2012, 17:51 GMT
@Jochen
Until this bug is resolved upstream you can use the switches --ignore and --ignoregroups to flag the packages you don't want to upgrade/update to resolve your downgrade issue; also as this will probably take a time to fix, you might as well fill the #IgnorePkg and #IgnoreGroup fields in /etc/pacman.conf to make pacman allways ignore the problematic packages without further manual intervention.
Last, if using KWin GLES is a must for you read my above statement about the PKGBUILD provided by @Mladen - as I already said GLES works perfect, at least in the build I did.

Graphics: Card-1: Intel Core Processor Integrated Graphics Controller bus-ID: 00:02.0 chip-ID: 8086:0046
Card-2: Advanced Micro Devices [AMD] nee ATI Madison [Radeon HD 5000M Series] bus-ID: 01:00.0 chip-ID: 1002:68c1
X.Org: 1.13.0 driver: intel Resolution: 1600x900@60.1hz
Comment by Jochen (Parzival) - Saturday, 27 October 2012, 08:29 GMT
@Martin
Thanks for your help. I never had to use the #IgnorePkg fields with Arch Linux before and didn't know of their existance!
Comment by ValdikSS (ValdikSS) - Wednesday, 31 October 2012, 12:52 GMT
KDE is now built with fix-mesa9.patch
Git commit 6cf057777555a5d0c834de3a0165a62916cf3b40 by Fredrik Höglund.
Committed on 30/10/2012 at 18:20.
Pushed by fredrik into branch 'KDE/4.9'.

kwin/glx: Avoid MSAA configs in initBufferConfigs()

It appears that we're accidentally choosing an MSAA config with the
Intel driver in Mesa 9.0. So change the algorithm to take the values
of GLX_SAMPLES and GLX_SAMPLE_BUFFERS into account.

Found by Kenneth Graunke.

M +20 -1 kwin/scene_opengl_glx.cpp

http://commits.kde.org/kde-workspace/6cf057777555a5d0c834de3a0165a62916cf3b40


Thanks, Andrea Scarpino! Please test the latest KDE with latest mesa and if everything is OK, i'll request closure.
Comment by Andrea Scarpino (BaSh) - Wednesday, 31 October 2012, 13:14 GMT
That is already applied in kdebase-workspace 4.9.2-6 but it fixes the slow down only.
Comment by ValdikSS (ValdikSS) - Wednesday, 31 October 2012, 17:16 GMT
The slowdown gone, but I have screen freeze issue now. Like, the screen is not always updated and if you click somewhere you think nothing happened but if you minimize and restore window, you see that click worked.
Comment by Andrea Scarpino (BaSh) - Tuesday, 06 November 2012, 20:13 GMT
Andreas this has been fixed from the KDE side, but there's a patch that have to be applied to mesa too; see https://bugs.freedesktop.org/show_bug.cgi?id=55856 for info. Thanks
Comment by Andreas Radke (AndyRTR) - Tuesday, 06 November 2012, 20:42 GMT
There's so far no commit in mesa master or better stable 9.0 branch.
Comment by Andrea Scarpino (BaSh) - Wednesday, 07 November 2012, 07:08 GMT Comment by Martín Cigorraga (msx) - Wednesday, 07 November 2012, 18:30 GMT
Excellent news, thank you!
Comment by Andrea Scarpino (BaSh) - Saturday, 17 November 2012, 12:36 GMT
OpenGL works again with mesa 9.0.1.

I'm using kwin 4.9.80, someone with 4.9.3 should confirm.
Comment by Javier Viñal (fjvinal) - Saturday, 17 November 2012, 13:00 GMT
I am using KDE 4.9.3 and mesa 9.0.1 with an ATI card, and it continues when the same bugs when using OpenGl for desktop effects (menus are not presented properly and very slow desktop in general). Reverting to XRender makes all works properly.
Comment by Andrea Scarpino (BaSh) - Saturday, 17 November 2012, 13:01 GMT
I'm using an Intel card.
Comment by Jochen (Parzival) - Saturday, 17 November 2012, 13:54 GMT
Everything works again on my machine:

- Intel HD4000
- xf86-video-intel 2.20.13-1
- kdelibs 4.9.3-2
- mesa 9.0-1
Comment by Flat Eric (flateric) - Saturday, 17 November 2012, 16:58 GMT
Works fine again!

ATI x1400 - driver radeon
KDE 4.9.3
Compositing type: OpenGL

Upgraded:
upgraded libglapi (9.0-1 -> 9.0.1-1)
upgraded libgl (9.0-1 -> 9.0.1-1)
upgraded ati-dri (9.0-1 -> 9.0.1-1)
upgraded libgbm (9.0-1 -> 9.0.1-1)
upgraded libegl (9.0-1 -> 9.0.1-1)
upgraded libgles (9.0-1 -> 9.0.1-1)
upgraded mesa (9.0-1 -> 9.0.1-1)

And rebooted...

Thanks!

Loading...