Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31939 - [mythtv] mythtv-setup freezes, segfaults when entering some sub-menus after 0.26 upgrade

Attached to Project: Community Packages
Opened by Aaron Lindsay (aclindsa) - Sunday, 14 October 2012, 00:42 GMT
Last edited by Jonathan Conder (PirateJonno) - Tuesday, 09 April 2013, 09:56 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jonathan Conder (PirateJonno)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
mythtv-setup worked fine under 0.25 - I was able to use it to initially configure Myth. After the recent upgrade to 0.26, I am able to start mythtv-setup, but if I enter some of the sub-menus (i.e. "2. Capture cards"), the menu appears to freeze. If I then hit ESC and attempt to navigate the upper-level menu using the arrow keys, mythtv-setup segfaults (Note: hitting ESC by itself doesn't appear to be enough to trigger the segfault). Entering the first menu item ("1. General") works as normal.

Notes:
* I am more than willing to help with debugging if I am pointed in the right direction.
* If this can be shown to be an upstream bug, I will be glad to file a bug report in the appropriate place(s).

Additional info:
* Fully-updated x86_64 Arch install (as of Oct. 13, 2012)
* xorg-server 1.13.0-2
* xf86-video-intel 2.20.9-2
* mythtv 1:0.26.0-1
* Attached are two gdb backtraces

Steps to reproduce:
1. $ mythtv-setup
2. Type down arrow key on keyboard to select "2. Capture cards", then Enter key. Menu freezes.
3. Type Esc on keyboard, then down arrow key. Observe segfault.

GDB output:
* I ran mythtv-setup under gdb. After step 2 above (when the menu is frozen), I did Ctrl-C in gdb and got a backtrace. This output is shown in mythtv-setup.gdb1.log (attached).
* I also ran mythtv-setup under gdb without ever artificially stopping it (i.e. no Ctrl-C). After following steps 1-3 above and observing the segfault, I gathered another backtrace (mythtv-setup.gdb2.log).
This task depends upon

Closed by  Jonathan Conder (PirateJonno)
Tuesday, 09 April 2013, 09:56 GMT
Reason for closing:  Upstream
Additional comments about closing:  haven't heard anything for a while so I'm going to assume you followed this up upstream
Comment by Jonathan Conder (PirateJonno) - Monday, 26 November 2012, 01:47 GMT
I would suggest you report this upstream if you haven't already. Thanks for providing such detailed output, but all I can gather is that it's probably a bug in the intel drivers, or maybe in mythtv itself. In either case, it is certainly an upstream issue, since the mythtv package hasn't been patched or anything. Also, you might want to try building something from the fixes branch and see if that works.

Loading...