Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31917 - [opencv] Requires rebuild due to so name change in openexr 1.7.1

Attached to Project: Arch Linux
Opened by Kartik Mohta (kartikmohta) - Friday, 12 October 2012, 18:41 GMT
Last edited by Eric Belanger (Snowman) - Saturday, 13 October 2012, 06:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Programs using the opencv highgui library fail to compile due to the so-name change in openexr 1.7.1. The exact error is:

/usr/bin/ld: warning: libIlmImf.so.6, needed by /usr/lib/libopencv_highgui.so, not found (try using -rpath or -rpath-link)


Additional info:
* package version(s)
OpenCV 2.4.2-2
openexr 1.7.1-1

Steps to reproduce:
Compile a program using the libopencv_highgui.so OpenCV library.
This task depends upon

Closed by  Eric Belanger (Snowman)
Saturday, 13 October 2012, 06:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  We're currently rebuilding the other packages.
Comment by Kyle Bradfield (walmartshopper) - Saturday, 13 October 2012, 03:41 GMT
Adding a vote because this prevents Digikam from starting.
Comment by Greg (dolby) - Saturday, 13 October 2012, 04:21 GMT
Its not just opencv affected. Some other packages that need a rebuild:
digikam
kipi-plugins
python2
libkface
kdebase-runtime
kdelibs
imagemagick
Comment by Greg (dolby) - Saturday, 13 October 2012, 04:56 GMT

Loading...