Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31912 - [gparted] GParted Shortcut Crashes X Server

Attached to Project: Arch Linux
Opened by Daniel (weirddan455) - Friday, 12 October 2012, 10:58 GMT
Last edited by Giovanni Scafora (giovanni) - Monday, 26 November 2012, 15:35 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

I'm using gparted version 0.14.0-1 which was just updated yesterday. If I recall correctly, prior to this update, the shortcut did nothing probably because I haven't set up consolekit or polkit. I'm currently just launching XFCE manually using "startxfce4" from the console.

Anyway, today I clicked on the shortcut and my desktop just froze up. I could still move my mouse but none of the windows were responding to my clicks or my keyboard. I then hit Ctrl + Alt + F1 to find that gparted was prompting me for my password. I typed it in and then switched back over to X. When I did, it was still completley frozen. I had to Ctrl+Alt+F1 again and Ctrl+C to kill the X server and then restart it.

I looked at the shortcut and it's launching the command "gparted-pkexec". When launched from a terminal emulator, it correctly asks for the root password and then successfully launches. However, when clicking the shortcut it crashes X. I propose possibly changing the shortcut to launch "gksudo gparted" or something safer that doesn't have the possibility of killing X. This would require and additional dependency on gksu so may not be the best option. I marked severity at high since this has the possibility of loosing a user's data in X applications that would have to be improperly killed.
This task depends upon

Closed by  Giovanni Scafora (giovanni)
Monday, 26 November 2012, 15:35 GMT
Reason for closing:  Fixed
Comment by Jan de Groot (JGC) - Friday, 12 October 2012, 13:31 GMT
Do you have polkit-gnome installed? gparted-pkexec will ask you for the root password through a polkit authotization agent.
Comment by Daniel (weirddan455) - Friday, 12 October 2012, 23:54 GMT
OK so I just got home and ran some tests. It turns out the update to gparted had nothing to do with this change of behavior. It was my switch from initscripts/sysvinit to systemd. I switched back to initscripts to test. The shortcut does nothing when I use initscripts with or without polkit-gnome. It just returns this (even when I run "gparted-pkexec" in a terminal emulator, which always worked on systemd):

Error getting authority: Error initializing authority: Could not connect: No such file or directory

With systemd the behavior is crashes X without polkit-gnome but it actually works like it should with polkit-gnome.

Obviously the worst case scenario is systemd without polkit-gnome installed which leads to an X crash. Maybe polkit-gnome should be a dependency to avoid this?
Comment by Giovanni Scafora (giovanni) - Wednesday, 17 October 2012, 18:20 GMT
I cannot reproduce this bug on my local machines.
Comment by Peter Wu (Lekensteyn) - Monday, 26 November 2012, 01:20 GMT
  • Field changed: Percent Complete (100% → 0%)
Removing PolicyKit support and forcing a dependency on gksu is not nice. "kdesudo" also works as did PolicyKit. Please make gksu optional and re-add PolKit support.
Comment by Christian Hesse (eworm) - Monday, 26 November 2012, 13:05 GMT
I second that. Please remove gksu from dependencies and add polkit-gnome instead.
Comment by Giovanni Scafora (giovanni) - Monday, 26 November 2012, 14:36 GMT
Done.
Let me know if I can close this bug report.
Comment by Peter Wu (Lekensteyn) - Monday, 26 November 2012, 15:30 GMT
Minor detail:

polkit-gnome: to run gparted directly from menu in GNOME
On KDE, polkit-kde is required by kdebase-workspace and polkit-qt by kdelibs, so no additional messages need to be added for KDE.

I am fine with either description and this bug can be closed as the dependency issues is solved.

Loading...