Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#31887 - [poppler,cairo] pdf printing/rendering problem

Attached to Project: Arch Linux
Opened by Alexey (Khumarahn) - Wednesday, 10 October 2012, 21:02 GMT
Last edited by Jan de Groot (JGC) - Friday, 02 November 2012, 17:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No



I have troubles printing some pdf documents like
with evince, xournal, zathura.

Documents look weird on "print preview" and on paper. I am attaching
screenshots of what document should look like and what it looks like on
print preview and paper. scr0.png - right, scr1.png - actual.

Command "pdftocairo -pdf myfile.pdf mynewfile.pdf"
produces a new pdf that looks wrong from the beginning,
so I assume this problem is with poppler/cairo.

pdf2ps produced .ps that looks and prints correctly

okular displays and prints original pdf correctly

I have another computer with gentoo linux, it doesn't have this
problem. May be this is because it runs older versions of most packages,
say, curent version of poppler is 0.18.4 compared to 0.20.3 in arch.

Additional info:
I would provide info if I knew what exactly.

Steps to reproduce:
open evince and try to print/preview pdf file from here:
   scr1.png (21.9 KiB)
   scr0.png (97.8 KiB)
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 02 November 2012, 17:52 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Saturday, 20 October 2012, 11:00 GMT
There's a new poppler in extra now and also new cairo in testing. Please check if the issue is still present. If so then check/report it upstream.
Comment by gsc (xgdgsc) - Friday, 02 November 2012, 15:36 GMT
It seems fixed for me after upgrading cairo and poppler. Evince prints correctly now.
Comment by Alexey (Khumarahn) - Friday, 02 November 2012, 15:56 GMT
I confirm, updates fixed this.