Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31823 - [wicd] systemd suspend breaks wifi roaming

Attached to Project: Arch Linux
Opened by Olivier (litemotiv) - Saturday, 06 October 2012, 08:28 GMT
Last edited by Dave Reisner (falconindy) - Sunday, 04 November 2012, 17:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

systemd 194-1
wicd 1.7.2.4-3

With systemd handling suspend actions, wicd is not taking the proper actions on resume. The result is that waking up in the same location re-establishes the wifi connection, but when resuming in another location it is not triggered to rescan and reconnect to a new network. This issue does not occur when using pm-utils instead of systemd to suspend.

A workaround has been posted on the forums, but i am not sure if this is the best way to deal with this:

https://bbs.archlinux.org/viewtopic.php?pid=1158787#p1158787

This involves changing the /usr/sbin/wicd script to include:

if [[ $1 == 'pre' ]] && [[ $2 == 'suspend' ]] ; then
exec /usr/bin/python2 -O /usr/share/wicd/daemon/suspend.py
elif [[ $1 == 'pre' ]] && [[ $2 == 'hibernate' ]] ; then
exec /usr/bin/python2 -O /usr/share/wicd/daemon/suspend.py
elif [[ $1 == 'post' ]] && [[ $2 == 'suspend' ]] ; then
exec /usr/bin/python2 -O /usr/share/wicd/daemon/autoconnect.py
elif [[ $1 == 'post' ]] && [[ $2 == 'hibernate' ]] ; then
exec /usr/bin/python2 -O /usr/share/wicd/daemon/autoconnect.py
fi
This task depends upon

Closed by  Dave Reisner (falconindy)
Sunday, 04 November 2012, 17:34 GMT
Reason for closing:  Not a bug
Comment by Olivier (litemotiv) - Friday, 02 November 2012, 19:12 GMT
This doesn't seem to be an issue anymore on my system, if there are no other confirmations then this can probably be closed in a few days.

Loading...