Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31814 - [gdm] "Could not get session id for session" (gnome-unstable)

Attached to Project: Arch Linux
Opened by Marti (intgr) - Friday, 05 October 2012, 19:07 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Saturday, 17 November 2012, 04:29 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: I enabled the gnome-unstable repository in pacman.conf and upgraded the system. Following the upgrade, GDM and gnome-session fail to come up. I'm starting gdm via systemd. This happens on 2 of my machines.

/etc/pam.d is not modified AFAIK -- there are no .pacnew files. And wtf is logind?

/var/log/gdm/:0-greeter.log has this to say:
gnome-session[2134]: WARNING: Could not get session id for session. Check that logind is properly installed and pam_systemd is getting used at login.

(gnome-settings-daemon:2157): power-plugin-WARNING **: session inhibition not available, gnome-session is not available
JS ERROR: !!! Exception was: Polkit.Error: No session for pid 2178
JS ERROR: !!! message = '"No session for pid 2178"'
JS ERROR: !!! fileName = '"/usr/share/gnome-shell/js/ui/components/polkitAgent.js"'
JS ERROR: !!! lineNumber = '329'
JS ERROR: !!! stack = '"0 anonymous()@/usr/share/gnome-shell/js/ui/components/polkitAgent.js:329
1 wrapper()@/usr/share/gjs-1.0/lang.js:204
2 anonymous("name" = ""polkitAgent"")@/usr/share/gnome-shell/js/ui/components/__init__.js:56
3 wrapper(""polkitAgent"")@/usr/share/gjs-1.0/lang.js:204
4 anonymous("name" = ""polkitAgent"", 0, [object Array])@/usr/share/gnome-shell/js/ui/components/__init__.js:22
5 anonymous()@/usr/share/gnome-shell/js/ui/components/__init__.js:21
6 wrapper()@/usr/share/gjs-1.0/lang.js:204
7 anonymous()@/usr/share/gnome-shell/js/ui/components/__init__.js:13
8 wrapper()@/usr/share/gjs-1.0/lang.js:204
9 anonymous()@/usr/share/gjs-1.0/lang.js:145
10 anonymous()@/usr/share/gjs-1.0/lang.js:239
11 start()@/usr/share/gnome-shell/js/ui/main.js:150
12 <TOP LEVEL>@<main>:1
"'
Window manager warning: Log level 32: Execution of main.js threw exception: Polkit.Error: No session for pid 2178
gnome-session[2134]: WARNING: Child process 2178 was already dead.
gnome-session[2134]: WARNING: Detected that screensaver has left the bus
JS ERROR: !!! Exception was: Polkit.Error: No session for pid 2200
JS ERROR: !!! message = '"No session for pid 2200"'
JS ERROR: !!! fileName = '"/usr/share/gnome-shell/js/ui/components/polkitAgent.js"'
JS ERROR: !!! lineNumber = '329'
JS ERROR: !!! stack = '"0 anonymous()@/usr/share/gnome-shell/js/ui/components/polkitAgent.js:329
1 wrapper()@/usr/share/gjs-1.0/lang.js:204
2 anonymous("name" = ""polkitAgent"")@/usr/share/gnome-shell/js/ui/components/__init__.js:56
3 wrapper(""polkitAgent"")@/usr/share/gjs-1.0/lang.js:204
4 anonymous("name" = ""polkitAgent"", 0, [object Array])@/usr/share/gnome-shell/js/ui/components/__init__.js:22
5 anonymous()@/usr/share/gnome-shell/js/ui/components/__init__.js:21
6 wrapper()@/usr/share/gjs-1.0/lang.js:204
7 anonymous()@/usr/share/gnome-shell/js/ui/components/__init__.js:13
8 wrapper()@/usr/share/gjs-1.0/lang.js:204
9 anonymous()@/usr/share/gjs-1.0/lang.js:145
10 anonymous()@/usr/share/gjs-1.0/lang.js:239
11 start()@/usr/share/gnome-shell/js/ui/main.js:150
12 <TOP LEVEL>@<main>:1
"'
Window manager warning: Log level 32: Execution of main.js threw exception: Polkit.Error: No session for pid 2200
gnome-session[2134]: WARNING: Detected that screensaver has left the bus
gnome-session[2134]: WARNING: App 'gnome-shell.desktop' respawning too quickly


Additional info:
* package version(s)
gdm 3.6.0-1
gnome-shell 3.6.0-1
polkit 0.107-4
polkit-gnome 0.105-1
...
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Saturday, 17 November 2012, 04:29 GMT
Reason for closing:  Not a bug
Comment by Jan Alexander Steffens (heftig) - Friday, 05 October 2012, 22:28 GMT
Is systemd-logind running? Does "loginctl list-seats" and "loginctl list-sessions" work? Even when logging in via a getty, you should have a session.
Comment by Marti (intgr) - Saturday, 06 October 2012, 17:28 GMT
Yes...
% loginctl list-seats
SEAT
seat0

1 seats listed.
% loginctl list-sessions
SESSION UID USER SEAT
c2 1000 marti seat0
c5 1000 marti seat0
c6 1000 marti seat0
c7 120 gdm seat0
c10 1000 marti

5 sessions listed.
Comment by Jan Alexander Steffens (heftig) - Saturday, 06 October 2012, 17:38 GMT
pacman -Qii pambase reports no modified files?
Comment by Marti (intgr) - Saturday, 06 October 2012, 17:54 GMT
Nope...
Backup Files:
UNMODIFIED /etc/pam.d/system-auth
UNMODIFIED /etc/pam.d/system-local-login
UNMODIFIED /etc/pam.d/system-login
UNMODIFIED /etc/pam.d/system-remote-login
UNMODIFIED /etc/pam.d/system-services
UNMODIFIED /etc/pam.d/other
Comment by Marti (intgr) - Monday, 08 October 2012, 19:50 GMT
Well after hours of debugging and just trying random things I could think of, I straced gdm... And wading through the megabytes of noise was worthwhile, I found this critical line:
[pid 2063] open("/proc/1/cgroup", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)

I'm mounting /proc with options hidepid=2 -- which hides other users' processes. It never caused me a problem so far. But apparently Gnome 3.6 relies on poking around in the details of the init process. It would be sad to lose this security feature on all Gnome desktops. I'll try to bring this up with upstream.

Loading...