Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31800 - [imagemagick] Running import command when there is a right click menu in GTK app, results in error

Attached to Project: Arch Linux
Opened by Ernestas (ernetas) - Thursday, 04 October 2012, 09:00 GMT
Last edited by Eric Belanger (Snowman) - Friday, 12 October 2012, 20:08 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: import command from imagemagick package cannot grab a screenshot when there is an active right click menu.


Additional info:
I'm using newest software (yaourt -Syua gives no updates).
Fluxbox+Transmission+xterm+Imagemagick

Steps to reproduce:
1. Launch Transmission and xterm.
2. Run "sleep 2; import screenshot.jpg" and in the meantime right click in Transmission window any torrent.
3. Get the error:
import: unable to grab mouse `': Resource temporarily unavailable @ error/xwindow.c/XSelectWindow/9047.
This task depends upon

Closed by  Eric Belanger (Snowman)
Friday, 12 October 2012, 20:08 GMT
Reason for closing:  Not a bug
Comment by Jelle van der Waa (jelly) - Thursday, 04 October 2012, 13:10 GMT
Sounds like an imagemagick bug, please report it on their tracker
Comment by Eric Belanger (Snowman) - Friday, 12 October 2012, 20:07 GMT
When using import, you need to click on the window you want it to grab. If there is a right click menu then it messes up with the mouse. Doesn't seem as a bug. Anyway, if you want this behavior changed, ask upstream.

Loading...