Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#31782 - [makepkg] - Add lrzip compression support once libarchive is updated

Attached to Project: Pacman
Opened by John (graysky) - Wednesday, 03 October 2012, 08:01 GMT
Last edited by Allan McRae (Allan) - Saturday, 09 February 2013, 04:09 GMT
Task Type Feature Request
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 4.0.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Summary and Info: Attached patch adds ability for makepkg to compress to lrzip. This flyspray is a place-holder since the current release of libarchive (v3.0.4) does not have lzrip support activated by an oversight. Tim Kientzle commited the fix yesterday: https://github.com/libarchive/libarchive/pull/28

In my test cases, makepkg works just fine compressing to lrzip (running libarchive-git from the AUR).
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 09 February 2013, 04:09 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#23968 
Comment by Allan McRae (Allan) - Wednesday, 03 October 2012, 09:43 GMT
libarchive-3.0.4 does not have lrzip support activated because it has no lrzip support... It is only on the developmental branch.
Comment by John (graysky) - Wednesday, 03 October 2012, 11:46 GMT
You're right, Allan. I was mistaken in my description.

Loading...