Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#3177 - new udev rules causing problems with my ide cf device

Attached to Project: Arch Linux
Opened by asd asd (izaak) - Thursday, 15 September 2005, 19:57 GMT
Last edited by Jan de Groot (JGC) - Thursday, 15 September 2005, 21:58 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To Judd Vinet (judd)
Architecture not specified
Severity Low
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


udev version: 068-4

After inserting my cf card (via a pcmcia adapter) the exact opposite number of present partitions show up in /dev (hde[2-16] when there is only one primary partition). If I manually create the device, it is removed within a few seconds. This message repeats every few seconds in my syslog:

Sep 15 15:37:22 aminal /dev/ide/host2/bus0/target0/lun0: p1

Commenting out the following udev.rules fixes the problem:

# block device disk id's
#KERNEL=="hd*[!0-9]", ACTION=="add", IMPORT="/sbin/ata_id --export $tempnode"
#KERNEL=="hd*[!0-9]", ENV{ID_SERIAL}=="?*", SYMLINK+="$env{ID_TYPE}/by-id/ata-$env{ID_MODEL}_$env{ID_SERIAL}"
#KERNEL=="hd*[0-9]", ACTION=="add", IMPORT{parent}=="ID_*", SYMLINK+="$env{ID_TYPE}/by-id/ata-$env{ID_MODEL}_$env{ID_SERIAL}-part%n"

#KERNEL=="sd*[!0-9]", ACTION=="add", SYSFS{ieee1394_id}=="*", IMPORT="/bin/echo -e 'ID_SERIAL=$sysfs{ieee1394_id}\nID_BUS=ieee1394\nID_TYPE=disk'"
#KERNEL=="sd*[!0-9]", ACTION=="add", ENV{ID_SERIAL}=="", IMPORT="/sbin/usb_id -x"
#KERNEL=="sd*[!0-9]", ACTION=="add", ENV{ID_SERIAL}=="", IMPORT="/sbin/scsi_id -g -x -s %p"
#KERNEL=="sd*[!0-9]", ACTION=="add", ENV{ID_SERIAL}=="", IMPORT="/sbin/scsi_id -g -x -a -s %p"
#KERNEL=="sd*[!0-9]", ACTION=="add", ENV{ID_SERIAL}=="?*", SYMLINK+="$env{ID_TYPE}/by-id/$env{ID_BUS}-$env{ID_SERIAL}"
#KERNEL=="sd*[0-9]", ACTION=="add", IMPORT{parent}=="ID_*"
#KERNEL=="sd*[0-9]", ENV{ID_SERIAL}=="?*", SYMLINK+="$env{ID_TYPE}/by-id/$env{ID_BUS}-$env{ID_SERIAL}-part%n"

# Skip id for ram / loop / fd
#SUBSYSTEM=="block", KERNEL=="ram*", GOTO="no_volume_id"
#SUBSYSTEM=="block", KERNEL=="loop*", GOTO="no_volume_id"
#SUBSYSTEM=="block", KERNEL=="fd*", GOTO="no_volume_id"

#SUBSYSTEM=="block", KERNEL=="*[!0-9]", ACTION=="add", ENV{ID_TYPE}=="?*", IMPORT="/sbin/path_id %p", SYMLINK+="$env{ID_TYPE}/by-path/$env{ID_PATH}"
#SUBSYSTEM=="block", KERNEL=="*[0-9]", ACTION=="add", IMPORT{parent}=="ID_*"
#SUBSYSTEM=="block", KERNEL=="*[0-9]", ACTION=="add", ENV{ID_PATH}=="?*", SYMLINK+="$env{ID_TYPE}/by-path/$env{ID_PATH}-part%n"

# volume-label/uuid
#SUBSYSTEM=="block", KERNEL=="*[!0-9]", SYSFS{removable}=="1", GOTO="no_volume_id"
#SUBSYSTEM=="block", KERNEL=="sr*", GOTO="no_volume_id"
#SUBSYSTEM=="block", KERNEL=="*[0-9]", ACTION=="add", IMPORT="/sbin/vol_id --export $tempnode"
#SUBSYSTEM=="block", KERNEL=="*[0-9]", ENV{ID_FS_UUID}=="?*", SYMLINK+="disk/by-uuid/$env{ID_FS_UUID}"
#SUBSYSTEM=="block", KERNEL=="*[0-9]", ENV{ID_FS_LABEL_SAFE}=="?*", SYMLINK+="disk/by-label/$env{ID_FS_LABEL_SAFE}"
#SUBSYSTEM=="block", LABEL="no_volume_id"
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 21 December 2005, 07:33 GMT
Reason for closing:  Fixed
Comment by Tobias Powalowski (tpowa) - Tuesday, 20 December 2005, 06:55 GMT
is this solved in 068-5?
or is it solved in 078?
Comment by Tobias Powalowski (tpowa) - Wednesday, 21 December 2005, 07:33 GMT
i close this now, because i think it's already fixed, added some pathces for this issue some time ago