Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31774 - [audacious] segfault

Attached to Project: Arch Linux
Opened by Alexandre Bique (babali) - Tuesday, 02 October 2012, 21:40 GMT
Last edited by Gaetan Bisson (vesath) - Friday, 12 October 2012, 01:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

just start audacious from the terminal :

WARNING: Audacious seems to be already running but is not responding.
(bootstrap.c:60) [mowgli_init]: mowgli_init() is a deprecated function, provided only for backwards compatibility with Mowgli-1. You should remove it if you no longer support using Mowgli-1.
Segmentation fault

Additional info:
* package version(s)
* config and/or log files etc.

Name : audacious
Version : 3.3.2-1
URL : http://audacious-media-player.org/
Licenses : custom:BSD
Groups : None
Provides : audacious-player
Depends On : gtk3 dbus-glib libguess libsm audacious-plugins
hicolor-icon-theme desktop-file-utils
Optional Deps : unzip: zipped skins support
Required By : None
Conflicts With : None
Replaces : audacious-player
Installed Size : 1408.00 KiB
Packager : Gaetan Bisson <bisson@archlinux.org>
Architecture : x86_64
Build Date : Mon 24 Sep 2012 12:27:57 AM CEST
Install Date : Tue 02 Oct 2012 11:37:58 PM CEST
Install Reason : Explicitly installed
Install Script : Yes
Description : Lightweight, advanced audio player focused on audio quality

This task depends upon

Closed by  Gaetan Bisson (vesath)
Friday, 12 October 2012, 01:31 GMT
Reason for closing:  No response
Comment by Gaetan Bisson (vesath) - Tuesday, 02 October 2012, 23:25 GMT
Works for me.

Would you care to look into that "Audacious seems to be already running but is not responding" warning, as well as to give us a backtrace of your segfault?
Comment by John Lindgren (jlindgren) - Wednesday, 03 October 2012, 00:37 GMT
"Audacious seems to be already running but is not responding" is just a side effect of the program already having crashed on the last run (because of a stale lock file).
Comment by Alexandre Bique (babali) - Wednesday, 03 October 2012, 15:29 GMT
It works fine at work, I'll get the backtrace at home.
Comment by Alexandre Bique (babali) - Wednesday, 03 October 2012, 19:32 GMT
abique@boby:~> gdb audacious
Reading symbols from /usr/bin/audacious...(no debugging symbols found)...done.
(gdb) r
Starting program: /usr/bin/audacious
warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
Traceback (most recent call last):
File "/usr/share/gdb/auto-load/usr/lib/libgobject-2.0.so.0.3200.4-gdb.py", line 9, in <module>
from gobject import register
File "/usr/share/glib-2.0/gdb/gobject.py", line 3, in <module>
import gdb.backtrace
ImportError: No module named backtrace
WARNING: Audacious seems to be already running but is not responding.
(bootstrap.c:60) [mowgli_init]: mowgli_init() is a deprecated function, provided only for backwards compatibility with Mowgli-1. You should remove it if you no longer support using Mowgli-1.
[New Thread 0x7fffefe5f700 (LWP 1265)]

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7de111e in open_path () from /lib/ld-linux-x86-64.so.2
(gdb) bt
#0 0x00007ffff7de111e in open_path () from /lib/ld-linux-x86-64.so.2
#1 0x00007ffff7de3289 in _dl_map_object () from /lib/ld-linux-x86-64.so.2
#2 0x00007ffff7de7882 in openaux () from /lib/ld-linux-x86-64.so.2
#3 0x00007ffff7de9636 in _dl_catch_error () from /lib/ld-linux-x86-64.so.2
#4 0x00007ffff7de7ac7 in _dl_map_object_deps ()
from /lib/ld-linux-x86-64.so.2
#5 0x00007ffff7ded859 in dl_open_worker () from /lib/ld-linux-x86-64.so.2
#6 0x00007ffff7de9636 in _dl_catch_error () from /lib/ld-linux-x86-64.so.2
#7 0x00007ffff7ded26c in _dl_open () from /lib/ld-linux-x86-64.so.2
#8 0x00007ffff4955026 in ?? () from /usr/lib/libdl.so.2
#9 0x00007ffff7de9636 in _dl_catch_error () from /lib/ld-linux-x86-64.so.2
#10 0x00007ffff49555fc in ?? () from /usr/lib/libdl.so.2
#11 0x00007ffff49550c1 in dlopen () from /usr/lib/libdl.so.2
#12 0x00007ffff6b958b1 in g_module_open () from /usr/lib/libgmodule-2.0.so.0
#13 0x00000000004189f0 in _start ()
(gdb) info threads
Id Target Id Frame
2 Thread 0x7fffefe5f700 (LWP 1265) "audacious" 0x00007ffff7394ea9 in do_sigwait () from /usr/lib/libpthread.so.0
* 1 Thread 0x7ffff7fda880 (LWP 1261) "audacious" 0x00007ffff7de111e in open_path () from /lib/ld-linux-x86-64.so.2
(gdb) t 2
[Switching to thread 2 (Thread 0x7fffefe5f700 (LWP 1265))]
#0 0x00007ffff7394ea9 in do_sigwait () from /usr/lib/libpthread.so.0
(gdb) bt
#0 0x00007ffff7394ea9 in do_sigwait () from /usr/lib/libpthread.so.0
#1 0x00007ffff7394f3b in sigwait () from /usr/lib/libpthread.so.0
#2 0x000000000041c96f in _start ()
(gdb) t 1
[Switching to thread 1 (Thread 0x7ffff7fda880 (LWP 1261))]
#0 0x00007ffff7de111e in open_path () from /lib/ld-linux-x86-64.so.2
(gdb) info locals
No symbol table info available.
(gdb) info registers
rax 0x7ffff7ffcdb0 140737354124720
rbx 0x0 0
rcx 0x7ffff7ffcdc0 140737354124736
rdx 0x7ffff7ffef48 140737354133320
rsi 0x7fffffffcf20 140737488342816
rdi 0x7fffffffce60 140737488342624
rbp 0x7fffffffcfe0 0x7fffffffcfe0
rsp 0x7fffffffce60 0x7fffffffce60
r8 0x7fffffffd05f 140737488343135
r9 0x0 0
r10 0x0 0
r11 0x0 0
r12 0x0 0
r13 0x7fffffffce60 140737488342624
r14 0x4 4
r15 0xffffffff 4294967295
rip 0x7ffff7de111e 0x7ffff7de111e <open_path+1438>
eflags 0x10202 [ IF RF ]
cs 0x33 51
ss 0x2b 43
ds 0x0 0
es 0x0 0
fs 0x0 0
gs 0x0 0
(gdb)
Comment by Alexandre Bique (babali) - Wednesday, 03 October 2012, 19:35 GMT
strace -o strace.log audacious
   strace.log (196.1 KiB)
Comment by John Lindgren (jlindgren) - Friday, 05 October 2012, 02:53 GMT
Well, what I see is Audacious trying to dlopen() a plugin (cue.so) and failing because libcue is not installed. What I don't see is why dlopen() should segfault in this situation. I tried to reproduce by uninstalling libcue from my system, and I did not get a segfault.
Comment by Gaetan Bisson (vesath) - Friday, 05 October 2012, 03:38 GMT
Why does audacious look for dynamic libraries under "/home/abique/local/lib"?

Loading...