Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31765 - [initscripts] the "hostname" command returns (none)

Attached to Project: Arch Linux
Opened by Ivan (gulpegaspe) - Tuesday, 02 October 2012, 11:27 GMT
Last edited by Tom Gundersen (tomegun) - Tuesday, 02 October 2012, 23:24 GMT
Task Type Bug Report
Category Arch Projects
Status Closed
Assigned To Tom Gundersen (tomegun)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
After upgrading initscripts to version 2012.09.1-1 the system is not able to retreive the hostname.
The "hostname" command returns (none).
Downgrading to 2012.08.3-2 version it works.


Additional info:
Package version: 2012.09.1-1
This thread: https://bbs.archlinux.org/viewtopic.php?id=149928


Steps to reproduce:
- upgrade initscripts
- reboot system
This task depends upon

Closed by  Tom Gundersen (tomegun)
Tuesday, 02 October 2012, 23:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  in testing
Comment by Tom Gundersen (tomegun) - Tuesday, 02 October 2012, 21:21 GMT
As pointed out by Marcus27, the problem is that /proc might not be mounted yet (unless using an initramfs). New initscripts in testing any minute. Please confirm if it fixes the problem for you.
Comment by Ivan (gulpegaspe) - Tuesday, 02 October 2012, 23:08 GMT
Tom, I tested the version 2012.09.2-1 (testing repository) and it fixed the problem. In my server I don't use an initramfs, that's why I had this problem. Thank you.
Comment by Tom Gundersen (tomegun) - Tuesday, 02 October 2012, 23:24 GMT
Thanks for reporting and testing!

Loading...