Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31758 - [openntpd] Time a few minutes ahead after suspend/resume

Attached to Project: Community Packages
Opened by Olivier Mehani (shtrom) - Tuesday, 02 October 2012, 02:06 GMT
Last edited by Balló György (City-busz) - Saturday, 14 September 2013, 18:42 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Vesa Kaihlavirta (vegai)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After suspend, with OpenNTPd running, the machine clock ends up being too fast by a few minutes. This seems linked to time gaps disturbing NTP estimates [0].

http://forums.fedoraforum.org/showpost.php?s=542c33c6be19e850f2be69917375d3a6&p=1438830&postcount=4|

Additional info:
* community/openntpd 3.9p1-19
* extra/pm-utils 1.4.1-5

Steps to reproduce:
* Install OpenNTPd
* Suspend the machine
* Go have lunch (or a nap, or a beer, or whatever takes some time)
* Resume the machine
* Behold the future

A fix to the problem seems to be to restart the daemon when resuming. The attached script, to be put in /etc/pm/sleep.d/90openntpd seems to fix the problem. Perhaps it should be included with the package?
This task depends upon

Closed by  Balló György (City-busz)
Saturday, 14 September 2013, 18:42 GMT
Reason for closing:  Works for me
Comment by Olivier Mehani (shtrom) - Sunday, 28 October 2012, 23:01 GMT
After more experience, the proposed solution does not work reliabliy...
Comment by Greg (dolby) - Monday, 19 November 2012, 07:27 GMT
pm-utils is dead. find the systemd solution instead.
Comment by Balló György (City-busz) - Saturday, 07 September 2013, 14:11 GMT
Please test it with the 'systemctl suspend' command.
Comment by Olivier Mehani (shtrom) - Monday, 09 September 2013, 23:42 GMT
I'll give it a go. The behaviour is not consistent, though, so it sometimes doesn't happen.
Comment by Olivier Mehani (shtrom) - Tuesday, 10 September 2013, 02:54 GMT
* local/openntpd 3.9p1-22
* local/pm-quirks 0.20100619-3
* local/pm-utils 1.4.1-6

Tested with 'systemctl suspend' for my 20-odd min lunch break; no time shift.

(I'll try some more times and report here, to be sure.)
Comment by Olivier Mehani (shtrom) - Tuesday, 10 September 2013, 03:21 GMT
How can I tell which command is called when, e.g., I press the power button?

I have
HandlePowerKey=hibernate
uncommented in my /etc/systemd/logind.conf, and replaced my /etc/acpi/handler.sh by a no-op (it only issues calls to logger, and I cannot see these messages anywher anyway; it's probably no longer used.).
Comment by Balló György (City-busz) - Tuesday, 10 September 2013, 07:25 GMT
Run the following command:

$ tail /var/log/pm-suspend.log

And check the last line. If it's an old date, then you are probably using systemd.
Comment by Olivier Mehani (shtrom) - Tuesday, 10 September 2013, 07:30 GMT
pm-utils doesn't seem to have run in a wile

> $ tail /var/log/pm-suspend.log
> Running hook /usr/lib/pm-utils/sleep.d/01grub resume suspend:
>
> /usr/lib/pm-utils/sleep.d/01grub resume suspend: success.
> Running hook /usr/lib/pm-utils/sleep.d/00powersave resume suspend:
>
> /usr/lib/pm-utils/sleep.d/00powersave resume suspend: success.
> Running hook /usr/lib/pm-utils/sleep.d/00logging resume suspend:
>
> /usr/lib/pm-utils/sleep.d/00logging resume suspend: success.
> Sun Jul 21 21:39:05 CEST 2013: Finished.
> $ ls -l /var/log/pm-suspend.log
> -rw-r--r-- 1 root root 451528 Jul 22 05:39 /var/log/pm-suspend.log

Comment by Balló György (City-busz) - Saturday, 14 September 2013, 18:42 GMT
I can't reproduce the problem with systemd, so I'm closing this bug. If you still experience this bug, feel free to request to reopen it.

Loading...