Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#31739 - [eclipse] All installed plugins gone after upgrading to 4.2.1

Attached to Project: Arch Linux
Opened by Marcin Rze┼║nicki (mrzeznicki) - Saturday, 29 September 2012, 22:21 GMT
Last edited by Ionut Biru (wonder) - Sunday, 28 October 2012, 18:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 21
Private No



After recent eclipse upgrade from 4.2.0 to 4.2.1 all of the plugins are gone, even those installed to /usr/share/eclipse (m2e, subclipse etc.) cannot be loaded.

Additional info:

I am able to see presumably all of the plugins I have installed under Help -> About Eclipse SDK -> Installation details, say, I have an entry there for m2e plugin. But when I try to open a maven's pom file I get:

No editor descriptor for id org.eclipse.m2e.editor.MavenPomEditor

Same goes for subclipse. I have it listed on plugins page but Eclipse perspective it installs is gone and it logs:

!ENTRY 4 0 2012-09-29 22:03:57.139
!MESSAGE Could not instantiate provider for project mock_operator.
!STACK 1 Could not instantiate provider for project mock_operator.
at org.eclipse.ui.internal.decorators.LightweightDecoratorDefinition.decorate(
at org.eclipse.ui.internal.decorators.LightweightDecoratorManager$
at org.eclipse.ui.internal.decorators.LightweightDecoratorManager.decorate(
at org.eclipse.ui.internal.decorators.LightweightDecoratorManager.getDecorations(
at org.eclipse.ui.internal.decorators.DecorationScheduler$1.ensureResultCached(
at org.eclipse.ui.internal.decorators.DecorationScheduler$
!SUBENTRY 1 4 0 2012-09-29 22:03:57.139
!MESSAGE Could not instantiate provider for project mock_operator.

There is a thread on bbs where various people (including me) have been reporting similar problems:

This task depends upon

Closed by  Ionut Biru (wonder)
Sunday, 28 October 2012, 18:58 GMT
Reason for closing:  Not a bug
Additional comments about closing:  3rd party from aur are the cause of this bug.
Comment by G R (gururise) - Sunday, 30 September 2012, 00:44 GMT
I can confirm the same problem on upgrade from eclipse 4.2.0 -> 4.2.1

I have lost all plugins. I've tried deleting the .eclipse folder, uninstalling/reinstalling the plugins, and even uninstalling and re-installing eclipse to no avail.
Comment by Robert (xroberx) - Sunday, 30 September 2012, 11:18 GMT
I can confirm this issue too.
Comment by Lucjan B (lucck) - Monday, 01 October 2012, 15:35 GMT
I can confirm this issue too.
Comment by Greg (dolby) - Monday, 01 October 2012, 15:40 GMT
This issue has 14 votes. It is clear an issue exists. Stop "confirming" it. Adding your vote above is enough.
Comment by Ionut Biru (wonder) - Monday, 01 October 2012, 15:59 GMT
i don't know what's the problem, it would be nice to give me hint on how to fix it.
Comment by Lucjan B (lucck) - Monday, 01 October 2012, 18:00 GMT
The step for reproduce the issue:

- Install eclipse 4.2.1 package
- install eclipse-cdt plugin (pacman -S eclipse-cdt)

Run the eclipse. Click about box, and check the installed plugins, the cdt plugin is not recognized, at all. C/C++ projects are unavailable, for example you are unable to make the C/C++ project.

Comment by Ionut Biru (wonder) - Monday, 01 October 2012, 18:10 GMT
is this a problem only on i686? I just installed eclipse-cdt and it was recognized.

i want to mention that this is the first time I install eclipse on this machine.
Comment by Lucjan B (lucck) - Monday, 01 October 2012, 18:23 GMT
The issue is on the x86-64 AMD64 platform. I will check the clipse + eclipse-cdt using another clear user acount and let you know. But when I deleted .eclipse directory it didn't helps at all

Comment by Bartosz Chmura (chmurli) - Monday, 01 October 2012, 18:48 GMT
I did revert to eclipse 4.2 but it didn't help. I removed ~/.eclipse dir and this help. Then I updated eclipse to 4.2.1 and plugins disappear again. Removing ~/.eclipse didnt help with 4.2.1. Platform 64bit
Comment by Lucjan B (lucck) - Monday, 01 October 2012, 19:16 GMT
I tested using new clear test account and CDT also doesn't work. CDT is not visible also when i tried to open C/C++ workspace. Cdt plugin is not visible in the eclipse 4.2.1 Please see the screenshoot:

Comment by Lucjan B (lucck) - Monday, 01 October 2012, 21:02 GMT
The issue can be resolved if you run eclipse as root and choose from menu: "Help->Check for Updates" I think that update arch package from eclipse repository will resolve the issue.

Comment by David Rosenstrauch (darose) - Tuesday, 02 October 2012, 04:52 GMT
As chmurli reported earlier, I too found that if you downgrade eclipse (to 4.2-1) and eclipse-cdt (to 8.1.0-2) and then rm -r ~/.eclipse, it restores your plugins. I have no idea what's breaking in the upgrade though.
Comment by Hugo Osvaldo Barrera (hobarrera) - Tuesday, 02 October 2012, 16:16 GMT
Removing .eclipse and creating a new workspace does not help at all either.
Comment by Andreas Trepczik (bzt) - Wednesday, 03 October 2012, 09:34 GMT
Everyone who is having problems with plugins not working:

Do you have eclipse-emf 2.8.0 from AUR installed? If so, then upgrade to 2.8.1, someone posted an updated PKGBUILD on the AUR page. After installing it, all my plugins are working again.

Also, don't be irritated by "Help > About Eclipse SDK". It seems to show plugin icons the second time you start up Eclipse. To check if your plugin is really working, open a View that this plugin provides.
Comment by David Rosenstrauch (darose) - Wednesday, 03 October 2012, 14:44 GMT
Confirmed; that fixes it for me. Thanks for posting!
Comment by Ionut Biru (wonder) - Wednesday, 03 October 2012, 18:49 GMT
so in the end, is was eclipse-emf...
Comment by Andreas G. (andrgrau) - Saturday, 06 October 2012, 11:04 GMT
I haven't installed eclipse-emf (neither via aur nor directly via eclipse) and I have the same errors. Installing emf doesn't fix the error.
Comment by Bartosz Chmura (chmurli) - Saturday, 06 October 2012, 12:11 GMT
I upgraded eclipse-emf but it didn't work, but then I followed lucck advise and this help.
Comment by Boris Bera (Boris-B) - Sunday, 28 October 2012, 18:39 GMT
I get the same problem. According to pacman, eclipse-emf was already at version 2.8.1. I reinstalled it and nothing changed.
Comment by Ionut Biru (wonder) - Sunday, 28 October 2012, 18:41 GMT
Is not only about eclipse-emf, check all the 3rd party plugins that you have installed from aur.
Comment by Boris Bera (Boris-B) - Sunday, 28 October 2012, 18:49 GMT
I believe I found my problem. It seems like eclipse-pdt didn't want to play nice at all. I removed it and it all worked again. I'm not sure if it needs to be updated or not. I'll have to checkout the aur page for it and see what version they have up on the official website.