Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31721 - [systemd] After upgrade to 192-1, cannot enumerate USB

Attached to Project: Arch Linux
Opened by Andrew D. (andrewd18) - Friday, 28 September 2012, 18:05 GMT
Last edited by Dave Reisner (falconindy) - Friday, 28 September 2012, 19:39 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

This morning I upgraded my system using -Syu, per this pacman.log:

[2012-09-28 08:11] Running 'pacman -Syu'
[2012-09-28 08:11] synchronizing package lists
[2012-09-28 08:12] starting full system upgrade
[2012-09-28 08:16] upgraded chromium (22.0.1229.79-1 -> 22.0.1229.79-2)
[2012-09-28 08:16] upgraded libtasn1 (2.13-1 -> 2.14-1)
[2012-09-28 08:16] upgraded gnutls (3.1.1-1 -> 3.1.2-1)
[2012-09-28 08:16] upgraded imagemagick (6.7.9.4-1 -> 6.7.9.8-1)
[2012-09-28 08:16] upgraded mkinitcpio-busybox (1.20.1-1 -> 1.20.2-1)
[2012-09-28 08:16] upgraded nodejs (0.8.9-1 -> 0.8.10-1)
[2012-09-28 08:16] upgraded qt (4.8.3-3 -> 4.8.3-4)
[2012-09-28 08:16] upgraded systemd (189-4 -> 192-1)
[2012-09-28 08:16] upgraded xkeyboard-config (2.6-1 -> 2.7-1)


Upon rebooting my laptop, I lost my ability to see connected USB devices or use my bluetooth mouse. The USB ports are still powered (as my phone is charging right now), but I can't see USB drives appear when plugged in.

Dmesg repeats the following over and over:

[ 632.950117] hub 8-0:1.0: unable to enumerate USB device on port 1
[ 634.750090] hub 2-0:1.0: connect-debounce failed, port 1 disabled
[ 636.550063] hub 2-0:1.0: connect-debounce failed, port 2 disabled
[ 638.350038] hub 2-0:1.0: connect-debounce failed, port 3 disabled
[ 638.576733] hub 2-0:1.0: unable to enumerate USB device on port 4

I'm going to downgrade to an older systemd to see if it fixes the issue.


Additional Information:

[andrew@Mk-Ultra ~]$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI M96 [Mobility Radeon HD 4650]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI RV710/730 HDMI Audio [Radeon HD 4000 series]
06:00.0 Network controller: Intel Corporation WiFi Link 5100
08:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8055 PCI-E Gigabit Ethernet Controller (rev 14)
0a:03.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
0a:03.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
0a:03.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)

[andrew@Mk-Ultra ~]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

[andrew@Mk-Ultra ~]$ uname -a
Linux Mk-Ultra 3.5.4-1-ARCH #1 SMP PREEMPT Sat Sep 15 08:12:04 CEST 2012 x86_64 GNU/Linux
This task depends upon

Closed by  Dave Reisner (falconindy)
Friday, 28 September 2012, 19:39 GMT
Reason for closing:  Not a bug
Comment by Andrew D. (andrewd18) - Friday, 28 September 2012, 18:27 GMT
Well, downgrading systemd didn't solve anything so I think my problem is elsewhere. I'd edit the [systemd] tag out of the bug report but apparently I can't. :(
Comment by Andrew D. (andrewd18) - Friday, 28 September 2012, 19:07 GMT
Yep. Confirming my USB ports just completely died on my laptop. Windows was freaking out too.
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 28 September 2012, 19:11 GMT
Try shutdown machine completely for few minutes...

Loading...