Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31687 - [scim, gtk2, gimp] gimp segfaults when changing font of selected text

Attached to Project: Arch Linux
Opened by Gaetan Bisson (vesath) - Tuesday, 25 September 2012, 05:53 GMT
Last edited by Isenmann Daniel (ise) - Tuesday, 25 June 2013, 19:01 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Isenmann Daniel (ise)
Gaetan Bisson (vesath)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

On an up-to-date x86_64 machine with gimp-2.8.2-1:
1. Start the GIMP.
2. Create a new picture.
3. Select the text tool.
4. Click anywhere on picture: a box appears above the text zone.
5. Click on that box's font input zone and type stuff: the GIMP crashes.

Here is a backtrace for this segfault:

(gimp:27988): Gdk-WARNING **: gdkdrawable-x11.c:874 drawable is not a pixmap or window

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff721d258 in gdk_x11_drawable_get_xdisplay () from /usr/lib/libgdk-x11-2.0.so.0
(gdb) bt
#0 0x00007ffff721d258 in gdk_x11_drawable_get_xdisplay () from /usr/lib/libgdk-x11-2.0.so.0
#1 0x00007fffeade337b in scim_bridge_key_event_gdk_to_bridge () from /usr/lib/gtk-2.0/2.10.0/immodules/im-scim.so
#2 0x00007fffeade2ab3 in ?? () from /usr/lib/gtk-2.0/2.10.0/immodules/im-scim.so
#3 0x00007fffeade2bb8 in ?? () from /usr/lib/gtk-2.0/2.10.0/immodules/im-scim.so
#4 0x00007ffff75aa389 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#5 0x00007ffff722153c in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#6 0x00007ffff3ea4475 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#7 0x00007ffff3ea47a8 in ?? () from /usr/lib/libglib-2.0.so.0
#8 0x00007ffff3ea4ba2 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#9 0x000000000047fa64 in app_run ()
#10 0x000000000047f55e in main ()

It could be SCIM's fault but it was last compiled in June...
This task depends upon

Closed by  Isenmann Daniel (ise)
Tuesday, 25 June 2013, 19:01 GMT
Reason for closing:  Won't fix
Additional comments about closing:  See my last comment.
Comment by Gaetan Bisson (vesath) - Tuesday, 25 September 2012, 06:01 GMT
Rebuilding the GIMP does not solve the issue.

This looks like that exact same bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=674827
Comment by Gaetan Bisson (vesath) - Tuesday, 25 September 2012, 06:22 GMT
Downgrading the GIMP does not fix the issue either.
However, uninstalling SCIM does...
Comment by cfr (cfr42) - Friday, 02 November 2012, 00:08 GMT
The Debian bug referred to above is now a bug against scim-gtk2-immodule rather than against gimp in Debian's bug tracker. Is this really a bug against scim in Arch?
Comment by Gaetan Bisson (vesath) - Friday, 02 November 2012, 11:23 GMT
cfr: We do not have as fine grained packages as Debian. But I guess you are right in that gtk2 is concerned too.
Comment by Isenmann Daniel (ise) - Tuesday, 11 June 2013, 20:54 GMT
Is this bug still valid? I can' reproduced it anymore with actual gimp.

I will close this bug if no one has any objections against it.
Comment by Gaetan Bisson (vesath) - Tuesday, 11 June 2013, 22:44 GMT
I can still reproduce it. Do you have SCIM installed?
Comment by Isenmann Daniel (ise) - Wednesday, 12 June 2013, 05:36 GMT
Yes, gimp and scim installed. Click on the box's font input zone and it works. Running under GNOME.
Comment by Gaetan Bisson (vesath) - Wednesday, 12 June 2013, 06:12 GMT
If it's just me, never mind then. No need to keep this open until I find the time to really investigate what is going on.
Comment by Isenmann Daniel (ise) - Tuesday, 25 June 2013, 19:01 GMT
Okay, I will close it like you suggested it.

Loading...