Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#31685 - [cups] Printing to Konica Minolta bizhub printer lets printer freezing

Attached to Project: Community Packages
Opened by Christian Jurk (commx) - Monday, 24 September 2012, 23:02 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 25 November 2012, 17:34 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I have a KONICA MINOLTA bizhub C203 printer at my company. When trying to print to it using any postscript-based drivers (even the correct one, that is for C352/C300 from foo2zjs) lets the printer freeze (the blue LED blinks, confirming that it may receive data, but it never stops it nor actually start printing. The printer must be hard-resetted to get it working again). I am not sure if that is a CUPS problem or at any of the postscript drivers, because printing from Ubuntu 12.10 RC works just fine (Ubuntu uses CUPS 1.5.3, while Arch has a decent newer version of it).

Additional info:
* package version(s)
cups 1.6.1-6
cups-filters 1.0.24-1
ghostscript 9.06-1
foo2zjs 20120909-1 from AUR

* config and/or log files etc.
Factory default configs are used (I didn't change anything there).

Steps to reproduce:
Create a Printer with any GUI (I used the GNOME printer settings for it) via socket://printer_address:9100 and select any postscript driver, or even the KONICA MINOLTA C352/C300 [en] which is shipped with foo2zjs. That driver is confirmed to be the correct one, and the same driver works perfectly with Ubuntu, so I don't think its a driver issue but I won't guarantee that. Printing the test page after the printer has been installed will lead the printer to freeze.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 25 November 2012, 17:34 GMT
Reason for closing:  Won't fix
Comment by Alexander F Rødseth (xyproto) (trontonic) - Tuesday, 25 September 2012, 14:43 GMT
Please report this upstream to the cups developers and if possible include a link to the bug report here. Thanks.
Comment by Andreas Radke (AndyRTR) - Tuesday, 25 September 2012, 15:01 GMT
First check you cupsd log files and set it to debug level. There are several projects that work together here. Maybe we can sort this out before you report it upstream.
Comment by Christian Jurk (commx) - Tuesday, 25 September 2012, 15:21 GMT
Please find the appropriate log files attached. They were generated in debug mode.
Comment by Andreas Radke (AndyRTR) - Tuesday, 25 September 2012, 15:56 GMT
This log is clean. So cups-filter and ghostscript seem to work well.

Maybe your device has an internal log file in its http menu. If there's nothing helpful you should file it upstream to the cups tracker.