Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#31673 - [recorder] deletes files in $HOME when attempting to clear temp dir

Attached to Project: Community Packages
Opened by Brent Hostetler (bch24) - Monday, 24 September 2012, 14:37 GMT
Last edited by Sergej Pupykin (sergej) - Tuesday, 25 September 2012, 14:55 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No



Unable to set temp directory from preferences in menu. You select the directory you want and it seems like it selects it. Go back into preferences it will show your temp directory set as your home directory. When you try to burn a project it will try to erase files in your home directory.

Additional info:
* package version(s)
* config and/or log files etc.

[rking@rking recorder]$ pacman -Qi recorder
Name : recorder
Version : 1.4.5-2
Licenses : GPL
Groups : None
Provides : None
Depends On : pygtk cdrkit dvd+rw-tools
Optional Deps : vcdimager: Support for VCD/SVCD modes
cdrdao: Support for VCD/SVCD modes
vorbis-tools: Support for ogg files on CD Audio mode
mpg123: Support for mp3 files on CD Audio mode
Required By : None
Conflicts With : None
Replaces : None
Installed Size : 64.00 KiB
Packager : Sergej Pupykin <>
Architecture : any
Build Date : Mon 20 Feb 2012 10:28:29 PM PST
Install Date : Mon 24 Sep 2012 07:16:37 AM PDT
Install Reason : Explicitly installed
Install Script : No
Description : A simple GTK+ disc burner.

Steps to reproduce:

1. Install recorder
2. Set temp directory
3. Try to burn

Will see errors as it tries to delete directories and files in your home directory as it attempts to clean its tmp dir.

1. Manually edit ~/.config/recorder/recorderrc and enter correct temp directory.

I consider this a serious bug since on initial run it will attempt to delete files in your home directory.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Tuesday, 25 September 2012, 14:55 GMT
Reason for closing:  Won't implement
Additional comments about closing:  moved to aur
Comment by Greg (dolby) - Monday, 24 September 2012, 15:10 GMT
From the project website:
"Recorder is no longer developed (in fact, I don't have a burner device). If you are looking for new features, you can grab the code and do it yourself or install another burning software."
Comment by Alexander F Rødseth (xyproto) (trontonic) - Tuesday, 25 September 2012, 14:48 GMT
Thanks for reporting.

Sergej, how about moving this package to unsupported (or just removing it), since it's both not maintained anymore and also may happen to delete files from users home directories?
Comment by Sergej Pupykin (sergej) - Tuesday, 25 September 2012, 14:54 GMT