Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31663 - [util-linux] problem with scriptlet on first install

Attached to Project: Arch Linux
Opened by Gerardo Exequiel Pozzi (djgera) - Sunday, 23 September 2012, 22:21 GMT
Last edited by Allan McRae (Allan) - Saturday, 17 November 2012, 02:51 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Tom Gundersen (tomegun)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description: on first install something goes wrong...

groupadd: Cannot determine your user name.
useradd: group '100' does not exist
useradd: the GROUP= configuration in /etc/default/useradd will be ignored
useradd: group 'uuidd' does not exist
install: invalid user 'uuidd'
error: command failed to execute correctly

Additional info:
util-linux-2.22-6

Steps to reproduce:
pacstrap /mnt
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 17 November 2012, 02:51 GMT
Reason for closing:  Fixed
Additional comments about closing:  util-linux-2.22.1-3 in [testing]
Comment by Tobias Powalowski (tpowa) - Monday, 24 September 2012, 12:15 GMT
The problem is filesystem is needed before installing util-linux.
One option would be to ship uuidd user and group in standard files.
Comment by JB (techryda) - Monday, 24 September 2012, 14:12 GMT
Filesystem needs to be added as a dependency...also, grep needs to added as a dep for filesystem, but that'll be a different bug report.


Edit: Sorry didn't see the earlier comment.
Comment by Mathijs van de Nes (mvdnes) - Sunday, 30 September 2012, 22:56 GMT
After the first install you also get an error regarding user uuidd upon booting (with both systemd and sysvinit). Reinstalling util-linux fixes this problem.
Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 14 October 2012, 13:44 GMT
  • Field changed: Percent Complete (100% → 0%)
"install: invalid user 'uuidd'"
For a newer install, since it still does not depend on filesystem. Of course in this case is not a big issue, such step is done for making a /run directory...
Comment by Gerardo Exequiel Pozzi (djgera) - Thursday, 18 October 2012, 06:50 GMT
It does not make much sense in creating /run/uuidd on first install, you will always reboot on destination. Maybe just addind "mkdir(/run/uuidd)" to post_upgrade(), but this is just in case if user wants to launch uuidd daemon...
Comment by David J. Haines (dhaines) - Thursday, 18 October 2012, 14:23 GMT
Is this related to the cron.daily/shadow message that I'm getting, as shown below?

no matching password file entry in /etc/shadow
add user 'uuidd' in /etc/shadow? No
pwck: no changes
Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 21 October 2012, 23:30 GMT
@David: no
Comment by Dave Reisner (falconindy) - Sunday, 04 November 2012, 03:07 GMT
Easier way to do this is to just use the UID/GID instead of the name in the install scriptlet, since we now hardcode it in /etc/passwd and /etc/group. I've fixed this in SVN.

Loading...