Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31658 - [linux] 3.4 - 3.6 rtl8712: tcp_recvmsg causes disk flood

Attached to Project: Arch Linux
Opened by Ben Ruijl (revelation60) - Sunday, 23 September 2012, 13:18 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 23 January 2013, 15:04 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

When I am browsing (using Chrome), at a seemingly random time I notice my system slowing down. When I check the logs, I see the attached message getting posted over and over again. This causes a disk flood within 20 seconds, writing 15 gbs of this same error message. As you can see, when this error occurs, the system becomes unusable almost instantly.

Removing the wireless network USB stick (RTL8191S) makes no difference when the flooding has started. Shutting down all network applications does not help either. I have had this problem for quite a while, but as of recently it happens every time and within 10 minutes from boot.

Below I've linked to a thread that shows that I am not the only one.


Additional info:

* See attached kernel trace log
* This thread: https://bbs.archlinux.org/viewtopic.php?pid=1165334#p1165334


Steps to reproduce:
Use the internet.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 23 January 2013, 15:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.7.x
Comment by Marisa Kisirame (Sayachan) - Tuesday, 25 September 2012, 16:58 GMT
Oh, looks like someone else has the same problem as me now.

I'm not alone :D

(attached is what my trace says)

In my case I have a RTL8188SU

Edit: I recommend disabling logging of kernel messages in the meantime, you can just go to /etc/syslog-ng/syslog-ng.conf and comment out the line that says

file("/proc/kmsg");

then restart the service.
   bug.txt (2.4 KiB)
Comment by Ben Ruijl (revelation60) - Wednesday, 26 September 2012, 14:50 GMT
Ok, this means we are both using the rtl8712 driver. I'll notify the developers, because this seems to be a driver error.
Comment by Larry Finger (lwfinger) - Wednesday, 26 September 2012, 18:22 GMT
Does this patch help?
Comment by Larry Finger (lwfinger) - Thursday, 27 September 2012, 14:59 GMT
This patch is also needed for r8712u since kernel 3.4. This bug causes problems when using SSL or SSH connections, and I do not think it is causing your problem. The patch is included in mainline and is queued for stable, but it is not yet included in 3.5.Y or 3.4.Y.
Comment by Ben Ruijl (revelation60) - Friday, 28 September 2012, 15:54 GMT
Thanks Larry! I have applied both patches and I haven't experienced the issue thus far. I'll let you know if I notice any problems in the coming days.
Comment by Thomas Bächler (brain0) - Friday, 28 September 2012, 16:44 GMT
Larry, can give us the corresponding mainline commit hashes? Thanks.
Comment by Larry Finger (lwfinger) - Friday, 28 September 2012, 17:25 GMT
The mainline commit is abf02cfc179bb4bd30d05f582d61b3b8f429b813 for r8712u_fix_recv_pkt.

The other patch was submitted in two parts, neither of which have reached mainline. They are in staging-next and will be merged into 3.7. The corresponding hashes are 5ca136a0cb96aabcb3c2158fb958677d55915f93 and fa16e5ea25d7dd83f663f333e70713aa2fa5dffe.

Commit 5ca136a is unlikely to be responsible for the fix, but either or both of the other two commits could be fixing the problem.
Comment by Ben Ruijl (revelation60) - Sunday, 30 September 2012, 09:06 GMT
The patches seem to be working!

Loading...