Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31646 - [linux] USB Sound Cards got mute

Attached to Project: Arch Linux
Opened by Andrzej Giniewicz (Giniu) - Saturday, 22 September 2012, 09:39 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 07 October 2012, 06:57 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Some USB Sound Cards got mute after update to kernel 3.5.4 because of one changeset:

http://git.kernel.org/?p=linux/kernel/git/stable/linux-stable.git;a=commitdiff;h=ca150f7ade5973c3bce19261bca6174d5c3cc342

It affects some (at least two) USB Sound Cards:

ID 0763:2012 Midiman M-Audio Fast Track Pro ( my card )
ID 04d2:5051 Altec Lansing Technologies ( see: https://bbs.archlinux.org/viewtopic.php?pid=1164850#p1164850 )

I don't know if all or only some cards are affected, but I believe that if there are two models, there will be more. The change can be removed with patch -R, even in linux-next (there are no new changes touching this code). After removing this change, sound works for me, and it was confirmed to fix the sound of ObsidianParis on forum also.

I've reported this to linux-kernel, but maybe it would be good to temporarily remove that changeset from our build of kernel before it gets resolved upstream?
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 07 October 2012, 06:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.5.5-1
Comment by Andrzej Giniewicz (Giniu) - Monday, 24 September 2012, 13:02 GMT
This is getting more severe, another user reported same issue with a lot more popular usb sound card:

ID 041e:3040 Creative Technology, Ltd SoundBlaster Live! 24-bit External SB0490
Comment by Andrzej Giniewicz (Giniu) - Saturday, 06 October 2012, 16:10 GMT

Loading...