Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31616 - Audacious takes up mime type that breaks folder open dialogs in Firefox

Attached to Project: Arch Linux
Opened by George (Vash63) - Thursday, 20 September 2012, 11:29 GMT
Last edited by Gaetan Bisson (vesath) - Thursday, 20 September 2012, 13:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Installing audacious immediately breaks the Firefox "Open containing folder" option when right clicking a downloaded item. It causes it to open Audacious instead of openning the default file manager at that location.


Additional info:
Version 3.3.1-1
Firefox 15.0.1-1


Steps to reproduce:
1. Download any file with Firefox.
2. Right click it on the downloads list, hit "Open containing folder."
3. Install audacious from pacman.
4. GOTO 2
This task depends upon

Closed by  Gaetan Bisson (vesath)
Thursday, 20 September 2012, 13:38 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#30034 
Comment by Gaetan Bisson (vesath) - Thursday, 20 September 2012, 13:36 GMT
Wouldn't it have been nice if you got to the bottom of this and reported this is due to inode/directory being in the MimeType field of audacious.desktop?

Anyhow, this file is directly shipped from upstream and I vaguely recall some discussion about how that entry was needed. I believe several desktop files may register the same mime type; your file explorer should do just that with inode/directory, and Firefox should let you decide what you want to open directories with.

Do you have precise arguments showing Audacious at fault here?
Comment by Gaetan Bisson (vesath) - Thursday, 20 September 2012, 13:38 GMT

Loading...